C语言实验——打印数字图形 (sdut oj)


C语言实验——打印数字图形

Time Limit: 1000MS  Memory Limit: 65536KB



Problem Description
从键盘输入一个整数n(1≤n≤9),打印出指定的数字图形。

Input
正整数n(1≤n≤9)。

Output
指定数字图形。

Example Input
5

Example Output
    1
   121
  12321
 1234321
123454321
 1234321
  12321
   121
    1
Hint
Author







参考代码



#include<stdio.h>
int main()
{
    int n;
    int i;
    int c;
    int temp;
    scanf("%d",&n);
    for(i = 1; i <= n; i++)
    {
        for(temp = i; temp < n; temp++)
        {
            printf(" ");
        }
        for(c = 1; c <= i; c++)
        {
            printf("%d",c);

        }
        for(c = i-1; c > 0; c--)

        {
            printf("%d",c);
        }
        printf("\n");
    }
    for(i = n-1; i > 0; i--)
    {
         for(temp = i; temp < n; temp++)
        {
            printf(" ");
        }
        for(c = 1; c <= i; c++)
        {
            printf("%d",c);

        }
        for(c = i-1; c > 0; c--)

        {
            printf("%d",c);
        }
        printf("\n");

    }

    return 0;
}



  • 2
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值