字符串排序 (sdut oj)


字符串排序

Time Limit: 1000MS  Memory Limit: 65536KB


Problem Description
输入3个字符串,按字典序从小到大进行排序。

Input
输入数据有一行,分别为3个字符串,用空格分隔,每个字符串长度不超过100。

Output
输出排序后的三个字符串,用空格分隔。

Example Input
abcd cdef bcde

Example Output
abcd bcde cdef

Hint
 
Author







参考代码


#include<stdio.h>
#include<string.h>
void stor_str(char a[][200],int n)
{
    int i,j;
    char t[200];
    for(i = 0; i < n; i++)
    {
        for(j = 0; j < n - i - 1; j++)
        {
            if(strcmp(a[j],a[j+1]) > 0)
            {
                strcpy(t,a[j]);
                strcpy(a[j],a[j+1]);
                strcpy(a[j+1],t);
            }
        }
    }
}
int main()
{
    char s[3][200];
    int i;
    for(i = 0; i < 3; i++)
    {
        scanf("%s",s[i]);
    }
    stor_str(s,3);
    for(i = 0; i < 3; i++)
    {
        printf("%s ",s[i]);
    }
    return 0;
}


  • 1
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值