swustoj旋转方阵(0484)

打印出一个旋转方阵,见Sample Output.
Description
输入一个整数n(1 <= n <= 20), n为方阵的行数。
Input
输出一个大小为n*n的距阵
Output
1
5
Sample Input
1
2
3
4
5
1 16 15 14 13
2 17 24 23 12
3 18 25 22 11
4 19 20 21 10
5 6 7 8 9
Sample Output
输出控制:每个数字占4位,居左。 
cout << setw(4) << setiosflags(ios::left) << a[i][j];
#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<iomanip>//这是输出控制头文件
using namespace std;
int main()
{
    int n;
    scanf("%d", &n);
    int a[25][25] = {0};
    int count = 1;
    int i = 0, j = 0, temp = 1;
    a[0][0] = 1;
    while (count < n*n)
    {
        while (i + 1 < n&& !a[i + 1][j])
        {
            count++;
            a[++i][j] = ++temp;
        }
        while (j + 1 < n && !a[i][j + 1])
        {
            count++;
            a[i][++j] = ++temp;
        }
        while (i - 1 >= 0 && !a[i - 1][j])//要写成i-1>=0 而不是i-1>0,这很重要——错误点
        {
            count++;
            a[--i][j] = ++temp;
        }
        while (j - 1 >= 0 && !a[i][j - 1])
        {
            count++;
            a[i][--j] = ++temp;
        }
        //printf("%d\n", temp);
    }
    for (i = 0;i < n;i++)
    {
        for (j = 0;j < n;j++)
            cout << setw(4) << setiosflags(ios::left) << a[i][j];//输出控制:每个数字占4位,居左。 
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值