swustoj经典矩阵(1173)

你的任务是打印如样例的矩阵。
Description
多组输入 
一个整数n(0<n<10).
Input
一个矩阵。
Output
1
3
Sample Input
1
2
3
4
5
6
1 1 1 1 1
1 2 2 2 1
1 2 3 2 1
1 2 2 2 1
1 1 1 1 1
Sample Output
换行用\r\n
#include<stdio.h>
#include<math.h>
#include<string.h>
int main()
{
    int n;
    int a[100][100];
    while (scanf("%d", &n) != EOF)
    {
        int count = 1;
        int x=0, y=0;
        memset(a, 0, sizeof(a));
        a[x][y] = 1;
        int t = 2 * n - 1;
        while (count <= n)
        {
            while (y + 1 < t && !a[x][y + 1])
            {
                a[x][++y] = count;
            }
            while (x + 1 < t&& !a[x + 1][y])
            {
                a[++x][y] = count;
            }
            while (y - 1 >= 0 && !a[x][y - 1])
            {
                a[x][--y] = count;
            }
            while (x - 1 >= 0 && !a[x - 1][y])
            {
                a[--x][y] = count;
            }
            /*for (int i = 0;i < t;i++)
            {
                for (int j = 0;j < t;j++)
                    printf("%4d", a[i][j]);
                printf("\n");
            }
            printf("\n");*/
            x = y = count;
            count++;
        }
        a[n - 1][n - 1] = n;
        for (int i = 0;i < t;i++)
        {
            for (int j = 0;j < t;j++)
            {
                if (j != 0)
                    printf(" %d", a[i][j]);
                else
                    printf("%d", a[i][j]);
            }
            printf("\r\n");
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值