poj 3278

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 95646 Accepted: 30002

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题意:

在一条笔直的道路上,农民要捉牛,给出农民和牛的位置,牛不动,农民有三种方式可以走,例如农民在5,牛在17. 农民可以倍数级走,5*2。可以向前走一步5+1,

向后走一步5-1,每一种方式都花费一分钟,问最少花费的时间可以捉到牛。

分析:

bfs所有可以到达的状态


code:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;

const int N = 200100;
int n, k;
struct node
{
    int x, step;
};
queue<node> Q;
int vis[N];

void BFS()
{   //搜索关于X的三种状态
    int X, STEP;
    while(!Q.empty())
    {
        node tmp = Q.front();
        Q.pop();
        X = tmp.x;
        STEP = tmp.step;
        if(X == k)
        {
            printf("%d\n",STEP);
            return ;
        }
        if(X >= 1 && !vis[X - 1]) //要保证减1后有意义,所以要X >= 1
        {
            node temp;
            vis[X - 1] = 1;
            temp.x = X - 1;
            temp.step = STEP + 1;
            Q.push(temp);
        }
        if(X <= k && !vis[X + 1])
        {
            node temp;
            vis[X + 1] = 1;
            temp.x = X + 1;
            temp.step = STEP + 1;
            Q.push(temp);
        }
        if(X <= k && !vis[X * 2])
        {
            node temp;
            vis[X * 2] = 1;
            temp.x = 2 * X;
            temp.step = STEP + 1;
            Q.push(temp);
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        while(!Q.empty()) Q.pop();
        memset(vis,0,sizeof(vis));
        vis[n] = 1;
        node t;
        t.x = n, t.step = 0;
        Q.push(t);
        BFS();
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值