Fibonacci Again

Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word “yes” if 3 divide evenly into F(n). Print the word “no” if not.

Sample Input

0
1
2
3
4
5

Sample Output

no
no
yes
no
no
no

代码1:

/*
0	1	2	3	4	5	6	7	8	9	10
7	11	18	29	47	76	123	199	322	521	843
no	no	yes	no	no	no	yes	no	no	no	yes
可以看出,从第二个开始,每隔三个都是yes,所以只需判断:输入的数对4取模是否等于二即可。 
*/
#include <stdio.h>
int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		if(n%4==2)
			printf("yes\n");
		else
			printf("no\n");
	}
	return 0;
}

代码2:

#include <stdio.h>
int main()
{
	int a[1000000]={0};
	a[0]=7%3;
	a[1]=11%3;
	int n,i;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=2;i<=n;i++)
			a[i]=(a[i-1]%3+a[i-2]%3)%3;//(a+b)%p=(a%p+b%p)%p
		if(a[n]==0)
			printf("yes\n");
		else
			printf("no\n");
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值