J - Greatest Common Increasing Subsequence HDU - 1423

 

This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

Input

Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

Output

output print L - the length of the greatest common increasing subsequence of both sequences.

Sample Input

1

5
1 4 2 5 -12
4
-12 1 2 4

Sample Output

2

题目大意:找到两个数组的最长公共子序列可以不连续

思路这就是一个模板题直接套模板就可以:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
   int N;
   scanf("%d",&N);
   while(N--)
   {
     int n;
     scanf("%d",&n);
     int a[1200],b[1200];
     int i,j;
     for(i=0;i<n;i++)
         scanf("%d",&a[i]);
     int m;scanf("%d",&m);
     for(j=0;j<m;j++)
        scanf("%d",&b[j]);
     int dp[600]={0};
     int maxx=-100;
     for(i=0;i<n;i++)
      {maxx=0;
            for(j=0;j<m;j++)
        {
            if(a[i]==b[j])
               dp[j]=maxx+1;
            if(a[i]>b[j])
               maxx=max(dp[j],maxx);
        }
      }
    int ans=-100;
    for(i=0;i<=m;i++)
        ans=max(ans,dp[i]);
    printf("%d\n",ans);
    if(N!=0)
    printf("\n");
   }
   return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值