D - The Falling Leaves UVA - 699

Each year, fall in the North Central region is accompanied by the brilliant colors of the leaves on the trees, followed quickly by the falling leaves accumulating under the trees. If the same thing happened to binary trees, how large would the piles of leaves become?

 


We assume each node in a binary tree "drops" a number of leaves equal to the integer value stored in that node. We also assume that these leaves drop vertically to the ground (thankfully, there's no wind to blow them around). Finally, we assume that the nodes are positioned horizontally in such a manner that the left and right children of a node are exactly one unit to the left and one unit to the right, respectively, of their parent. Consider the following tree:

 

The nodes containing 5 and 6 have the same horizontal position (with different vertical positions, of course). The node containing 7 is one unit to the left of those containing 5 and 6, and the node containing 3 is one unit to their right. When the "leaves" drop from these nodes, three piles are created: the leftmost one contains 7 leaves (from the leftmost node), the next contains 11 (from the nodes containing 5 and 6), and the rightmost pile contains 3. (While it is true that only leaf nodes in a tree would logically have leaves, we ignore that in this problem.)

 

Input 

The input contains multiple test cases, each describing a single tree. A tree is specified by giving the value in the root node, followed by the description of the left subtree, and then the description of the right subtree. If a subtree is empty, the value -1 is supplied. Thus the tree shown above is specified as 5 7 -1 6 -1 -1 3 -1 -1. Each actual tree node contains a positive, non-zero value. The last test case is followed by a single -1 (which would otherwise represent an empty tree).

 

Output 

For each test case, display the case number (they are numbered sequentially, starting with 1) on a line by itself. On the next line display the number of "leaves" in each pile, from left to right, with a single space separating each value. This display must start in column 1, and will not exceed the width of an 80-character line. Follow the output for each case by a blank line. This format is illustrated in the examples below.

 

Sample Input 

 

5 7 -1 6 -1 -1 3 -1 -1
8 2 9 -1 -1 6 5 -1 -1 12 -1
-1 3 7 -1 -1 -1
-1

 

Sample Output 

Case 1:
7 11 3

Case 2:
9 7 21 15

题目大意:就是一个搜索二叉树,然后问垂直的方向的和,

垂直和的意思如上图所示,上面是第一个例子。

解题思路:以第一个根为中点,搞一个一维数组,左子树中点减一递归,

右子树的中点加一递归,最后标记最左最右输出即可,很巧妙的方法,很佩服想出来的人。。。

代码如下:

#include<stdio.h>
#include<string.h>
int f[100000];
int left,right;
void slove(int x)   //
{
    int d;
    scanf("%d",&d);   //输入数,
    if(d==-1) return; //-1代表后面没有直接返回
    if(x>right)       //左右两个坐标
        right=x; 
    if(x<left)        //左坐标
        left=x;
    f[x]=f[x]+d;     // 用数组记录垂直和
    slove(x-1);      //先向左
    slove(x+1);      //再向右
}
int main()
{

    int  n,k=1;
    while(1)
    {
        left=10000;
        right=0;
        memset(f,0,sizeof(f));
        slove(100);                 //中点位置定位100够用
        if(right==0) return 0;
        printf("Case %d:\n",k++);
        int i;
        for( i=left; i<=right-1; i++)  //从左到右输出垂直和
        {
            printf("%d ",f[i]);
        }
        printf("%d",f[i]);
        printf("\n\n");
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值