POJ 1002 487-3279 (模拟 水题)

487-3279
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 278126 Accepted: 49638

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10. 

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows: 

A, B, and C map to 2 
D, E, and F map to 3 
G, H, and I map to 4 
J, K, and L map to 5 
M, N, and O map to 6 
P, R, and S map to 7 
T, U, and V map to 8 
W, X, and Y map to 9 

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010. 

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.) 

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number. 

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters. 

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line: 

No duplicates. 

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

Source

East Central North America 1999


题意:

分离给出的电话号码,统计重复的电话号码的数量。并按照格式输出。如果没有重复电话号码,输出“No duplicates. ”。

题目比较水,但是调试起来比较麻烦,n2我试了没有过去。所以去了结构体,直接用int数组存了电话号码。注意要处理输入的Q 和Z,也要注意输出的时候补全0。据说存放输入号码的数组需要大于300才能保证AC,一开始开的比较大也没有在意这个事情。总体来说是一道水题。就是坑比较多。


#include <iostream>
#include <iomanip>
#include <queue>
#include <stack>
#include <cstdio>
#include <cstring>
#include <map>
#include <cmath>
#include <algorithm>
using namespace std;

int  arr[110000];

inline int get(char& a){
	if(a <= '9' && a >= '0') return a - '0';
	if(a <= 'O') return (a - 'A') / 3 + 2;
	if(a <= 'S') return 7;
	if(a <= 'V') return 8;
	return 9;
}

int main()
{
	int casen, ttel, countn, i, top = 0;
	char str[310];
	bool flag = 0;
	scanf("%d", &casen);
	while(casen--){
		scanf("%s", str);
		ttel = 0;
		countn = 1000000;
		for(i = 0; str[i] != 0; i++){
			if(str[i] == '-' || str[i] == 'Q' || str[i] == 'Z') continue;
			ttel += countn * get(str[i]);
			countn = countn / 10;
		}
		arr[top++] = ttel;
	}
	sort(arr, arr + top);
	i = 1;
	while(1){
		countn = 1;
		if(i >= top) break;
		while(arr[i] == arr[i - 1]) {
			i++; countn++;
			flag = 1;
		}
		if(countn > 1)
			printf("%03d-%04d %d\n", arr[i - 1]/10000, arr[i - 1] % 10000, countn);
		i++;
	}
	if(!flag)	printf("No duplicates.\n");

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值