POJ 2277 Count Color(线段树)

Count Color
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 43095 Accepted: 13058

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. 

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board: 

1. "C A B C" Color the board from segment A to segment B with color C. 
2. "P A B" Output the number of different colors painted between segment A and segment B (including). 

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your. 

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

Source


题意:
给一个木条涂色,然后询问l,r之间一共多少种颜色。

思路:
比较裸的线段树。可以用按位取或来进行操作,避免麻烦的颜色判重。注意给出的数据可能有 l > r的情况。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX 100010 
#define lc (n << 1)
#define rc (n << 1 | 1)
#define mid (l + r >> 1)
using namespace std;

struct node{
	int sum, lz;
}sgm[MAX * 5];

void build(int n, int l, int r){
	sgm[n].lz = 0;
	if(l == r){
		sgm[n].sum = 2;
		return;
	}
	build(lc, l, mid);
	build(rc, mid + 1, r);
	sgm[n].sum = 2;
}

void lazy(int n, int l, int r){
	if(sgm[n].lz){
		sgm[lc].sum = sgm[n].lz;
		sgm[rc].sum = sgm[n].lz;
		sgm[lc].lz = sgm[rc].lz = sgm[n].lz;
		sgm[n].lz = 0;
	}
}

void update(int n, int l, int r, int L, int R, int num){
	if(l == L && r == R){
		sgm[n].sum = num;
		sgm[n].lz = num;
		return;
	}
	lazy(n,l,r);
	if(L > mid)  update(rc, mid + 1, r, L, R, num);
	else if(R <= mid) update(lc, l, mid, L, R, num);
	else{
		update(lc, l, mid, L, mid, num);
		update(rc, mid + 1, r, mid + 1, R, num);
	}
	sgm[n].sum = (sgm[lc].sum | sgm[rc].sum);
}

int get(int n, int l, int r, int L, int R){
	if(l == L && r == R)	return sgm[n].sum;
	lazy(n, l, r);
	if(L > mid)		return get(rc, mid + 1, r, L, R);
	else if(R <= mid)	return get(lc, l, mid, L, R);
	else	return get(lc, l, mid, L, mid) | get(rc, mid + 1, r, mid + 1, R);
}

int cnt(int num){
	int res = 0;
	while(num > 0){
		while(!(num & 1)) num = num >> 1;
		num = num >> 1;
		res++;
	}
	return res;
}


int main()
{
	int len, col, tot, i, res, l, r, temp;
	char ord;
	scanf("%d%d%d", &len, &col, &tot);
	build(1,1,len);
	for(i = 0; i < tot; i++){
		getchar();
		scanf("%c", &ord);
		if(ord == 'C'){
			scanf("%d%d%d", &l, &r, &temp);
			if(l > r) swap(l,r);
			temp = 1 << temp;
			update(1,1,len,l,r,temp);
		}
		else{
			scanf("%d%d", &l, &r);
			if(l > r) swap(l,r);
			res = get(1,1,len,l,r);
			res = cnt(res);
			printf("%d\n", res);
		}
		
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值