HDU - 2602 Bone Collector (0-1背包)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2602

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

在这里插入图片描述

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output
One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
1
5 10
1 2 3 4 5
5 4 3 2 1

Sample Output
14

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1011;
struct node{
	int val, vol;
}bone[maxn];
int T, N, V;
int dp[maxn][maxn];
int main(void) {
	scanf("%d", &T);
	while (T--) {
		scanf("%d %d", &N, &V);
		for (int i = 1; i <= N; i++)
			scanf("%d", &bone[i].val);
		for (int i = 1; i <= N; i++)
			scanf("%d", &bone[i].vol);
		memset(dp, 0, sizeof(dp));
		for(int i=1;i<=N;i++)
			for (int j = 0; j <= V; j++) {
				if (bone[i].vol > j)
					dp[i][j] = dp[i - 1][j];
				else
					dp[i][j] = max(dp[i - 1][j], dp[i - 1][j - bone[i].vol] + bone[i].val);
			}
		printf("%d\n", dp[N][V]);
	}
	return 0;
}

滚动数组:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1000 + 5;
int T, N, V, value[maxn], volume[maxn], dp[maxn];
int main(void) {
	scanf("%d", &T);
	while (T--) {
		scanf("%d %d", &N, &V);
		memset(dp, 0, sizeof(dp));
		for (int i = 1; i <= N; i++)scanf("%d", &value[i]);
		for (int i = 1; i <= N; i++)scanf("%d", &volume[i]);
		for (int i = 1; i <= N; i++) 
			for (int j = V; j >= volume[i]; j--) 
				dp[j] = max(dp[j], dp[j - volume[i]] + value[i]);
		printf("%d\n", dp[V]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

JILIN.

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值