HDU - 1874 畅通工程续(最短路初级)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1874

Problem Description
某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。

Input
本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。

Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.

Sample Input
3 3
0 1 1
0 2 3
1 2 1
0 2
3 1
0 1 1
1 2

Sample Output
2
-1

完全的最短路,如下代码为dijkstra算法

#include<cstdio>
#include<vector>
#include<queue>
using namespace std;
const int inf = 0x3f3f3f3f;
const int maxn = 100 + 5;
int N, M;
struct edge{
	int to, w;
	edge(int b, int c) :to(b), w(c) {}
};
struct s_node {
	int id, dis;
	s_node(int _id, int _dis) :id(_id), dis(_dis) {}
	bool operator <(const s_node& x) const {
		return dis > x.dis;
	}
};

int main(void) {
	while (~scanf("%d %d", &N, &M)) {
		vector<edge>e[maxn];
		for (int i = 0; i < M; i++) {
			int a, b, c;
			scanf("%d %d %d", &a, &b, &c);
			e[a].push_back(edge(b, c));
			e[b].push_back(edge(a, c));
		}
		int S, T;
		scanf("%d %d", &S, &T);
		bool done[maxn];
		int dis[maxn];
		for (int i = 0; i < N; i++) {
			dis[i] = inf; done[i] = false;
		}
		priority_queue<s_node>pq;
		pq.push(s_node(S, 0));
		dis[S] = 0; 
		while (!pq.empty()) {
			s_node u = pq.top(); pq.pop();
			if (done[u.id])continue;
			done[u.id] = true;
			for (int i = 0; i < e[u.id].size(); i++) {
				int to = e[u.id][i].to, w = e[u.id][i].w;
				if (done[to])continue;
				if (dis[to] > dis[u.id] + w) {
					dis[to] = dis[u.id] + w;
					pq.push(s_node(to, dis[to]));
				}
			}
		}
		if (done[T])printf("%d\n", dis[T]);
		else printf("-1\n");
	}
	return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

JILIN.

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值