HDU-2139 Calculate the formula

HDU-2139 Calculate the formula

题目描述

You just need to calculate the sum of the formula: 1^2+3^2+5^2+……+ n ^2.

Input

In each case, there is an odd positive integer n.

Output

Print the sum. Make sure the sum will not exceed 2^31-1

Sample Input
3

Sample Output
10

思路

我绝对不会说最后就算找到公式,还是TLE;
记住,这一道题目的输入很大,不要用cin & cout!!!;

一开始就想到模拟做肯定白搭,所以用到了数学归纳法求解通式;

先给出求前n项平方和的证明(经典解法):

    设S=1^2+2^2+.+n^2
    已知(n+1)^3-n^3 = 3n^2+3n+1
    n^3-(n-1)^3 = 3(n-1)^2+3(n-1)+1
    ...
    ...
    ...
    2^3-1^3 = 3*1^2+3*1+1
    把上面n个式子相加得:(n+1)^3-1 = 3* [1^2+2^2+...+n^2] +3*[1+2+.+n] +n
    所以S= (1/3)*[(n+1)^3-1-n-(1/2)*n*(n+1)] = (1/6)*n*(n+1)*(2n+1)
    即 1^2+2^2+3^2+...+n^2=n*(n+1)*(2n+1)/6;

    我们把每一项都乘上2,那么上式就变为:2^2+4^2+6^2+...+(2n)^2=4*(1^2+2^2+3^2+...+n^2)=4*n*(n+1)*(2n+1)/6;

    即前2n项中偶数的平方和,

    由第一个式子,我们又可以知道前(2n+1)项数的平方和为:1^2+2^2+3^2+...+n^2+(n+1)^2+...+(2n+1)^2=(2n+1)*(2n+1+1)*(4n+2+1)/6;

    那么用第三个式子减去第二个式子,便得到了前2n+1个数中奇数的平方和,即前n个奇数的平方和:

    1^2+3^2+5^2+...+(2n+1)^2=(n+1)*(2n+1)*(2n+3)/3,

    所以就得到了前n个数中奇数的平方和公式:n*(n+1)*(n+2)/6.

代码

#include <iostream>
#include <algorithm>

using namespace std;
typedef unsigned long long ULL;

int main()
{
    long long n;
    while(~scanf("%lld",&n))
    {
        printf("%lld\n",n*(n+1)*(n+2) / 6);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值