【PAT】零碎技巧算法A1093-A1101


A1093 Count PAT’s


The string APPAPT contains two PAT’s as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT’s contained in the string.

Input Specification:
Each input file contains one test case. For each case, there is only one line giving a string of no more than 10
5
characters containing only P, A, or T.

Output Specification:
For each test case, print in one line the number of PAT’s contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

思路:A左边的P的个数,与A右边的T的个数的乘积,在对题目要求的mod取模。左边P的个数从左到右遍历即可,右边T的个数需要先求出所有T的个数,然后在从左向右遍历时遇到T就减去一个T。遇到A乘起来。

#include <cstdio>
#include <string>
#include <iostream>
using namespace std;
const int maxn=100010;
const long long mod=1000000007;
int main()
{
    string s;
    cin>>s;
    int leftp[maxn]={0};
    int rightt=0;
    for(int i=0;i<s.size();i++)
    {
        if(i>0)
            leftp[i]=leftp[i-1];
        if(s[i]=='P')
            leftp[i]++;
    }
    int ans=0;
    for(int i=s.size()-1;i>=0;i--)
    {
       
        if(s[i]=='T')
            rightt++;
        else if(s[i]=='A')
            ans=(ans+(leftp[i]*rightt)% 1000000007)%mod;
    }
    printf("%d\n",ans);
    return 0;
}


A1101 Quick Sort


There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
and for the similar reason, 4 and 5 could also be the pivot.
Hence in total there are 3 pivot candidates.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10
5
). Then the next line contains N distinct positive integers no larger than 10
9
. The numbers in a line are separated by spaces.

Output Specification:
For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
5
1 3 2 4 5
Sample Output:
3
1 4 5

思路:打两个表,一个表leftMax存的是在每一位处,它左边所有数中的最大值。另一个表rightMin存的是在每一位处,它右边所有数中的最小值。有了这两个表后,我们就可以枚举数组元素了,判断条件:
v[i] >= leftMax[i] and v[i] <= rightMin[i]
如果当前位大于等于他左侧最大的值,小于等于他右侧最小的值,则是符合partition的标兵。

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=100010;
int main()
{
    int n;
    int a[maxn];
    int leftmax[maxn];
    int rightmin[maxn];
    
    leftmax[0]=0;
    int ans[maxn];
    scanf("%d",&n);
    rightmin[n-1]=0x3fffffff;
    for(int i=0;i<n;i++)
    {
        scanf("%d",&a[i]);
    }
    
    for(int i=1;i<n;i++)
    {
        leftmax[i]=max(leftmax[i-1],a[i-1]);
    }
    for(int i=n-2;i>=0;i--)
    {
        rightmin[i]=min(rightmin[i+1],a[i+1]);
    }
    int num=0;
    for(int i=0;i<n;i++)
    {
        if(leftmax[i]<a[i]&&rightmin[i]>a[i])
        {
            ans[num]=a[i];
            num+=1;
        }
    }
    sort(ans,ans+num);
    printf("%d\n",num);
    for(int i=0;i<num;i++)
    {
        printf("%d",ans[i]);
        if(i<num-1) printf(" ");
    }
    printf("\n");
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值