POJ3278 Catch That Cow 【BFS】

题目地址
Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17

Sample Output
4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

BFS+剪枝。
首先,当当前坐标大于目标坐标的时候就没必要再往前走和瞬间移动了。
其次,当原本起点就大于目标坐标的时候还需要bfs吗?直接减就行了。
30+ms过的,一直不懂怎么0ms。

#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
bool vis[200005];
struct node
{
    int n;
    int w;
    node(){}
    node(int nn,int ww)
    {
        n=nn;
        w=ww;
    }
};
int bfs(int s,int t)
{
    memset(vis,0,sizeof(vis));
    queue<node> q;
    q.push(node(s,0));
    while(!q.empty())
    {
        node p=q.front();
        q.pop();
        if(vis[p.n])continue;
        vis[p.n]=true;
        if(p.n==t)return p.w;
        if(p.n>0)q.push(node(p.n-1,p.w+1));
        if(p.n<t)q.push(node(p.n+1,p.w+1));
        if(p.n<t)q.push(node(p.n*2,p.w+1));
    }
    return -1;
}
int main()
{
    int s,t;
    while(scanf("%d%d",&s,&t)==2)
    {
        if(s>=t)printf("%d\n",s-t);
        else printf("%d\n",bfs(s,t));
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值