(尚学杯)C.Collection Game

Description
POI and POJ are pair of sisters, one is a master in “Kantai Collection”, another is an excellent competitor in ACM programming competition. One day, POI wants to visit POJ, and the pace that between their homes is made of square bricks. We can hypothesis that POI’s house is located in the NO.1 brick and POJ’s house is located in the NO.n brick. For POI, there are three ways she can choose to move in every step, go ahead one or two or three bricks. But some bricks are broken that couldn’t be touched. So, how many ways can POI arrive at POJ’s house?

Input

There are multiple cases.

In each case, the first line contains two integers N(1<=N<=10000) and M (1<=M<=100), respectively represent the sum of bricks, and broke bricks. Then, there are M number in the next line, the K-th number a[k](2<=a[k]<=n-1) means the brick at position a[k] was broke.

Output
Please output your answer P after mod 10007 because there are too many ways.
Sample Input

5 1

3

Sample Output
3
这题是一道斐波那契数列题,只是需要判断一下有什么点不能走

比赛的时候忘记特判了(还是有点紧张),LOL

代码:

#include <stdio.h>
#include <string.h>
#include <iostream>
#define mod 10007
using namespace std;
long long x,n,m;
long long num[10020];
bool flag[10020];
int main()
{
    while(~scanf("%lld%lld",&n,&m))
    {
        memset(flag,0,sizeof(flag));
        memset(num,0,sizeof(num));
        for(long long i=0; i<m; i++)
        {
            scanf("%lld",&x);
            flag[x]=1;
        }
        num[1]=1;
        if(!flag[2]) num[2]=1;
        if(!flag[3]) num[3]=num[2]+1;
        for(long long i=4; i<=n; i++)
        {
            if(flag[i])
                num[i]=0;
            else
                num[i]=(num[i-1]+num[i-2]+num[i-3])%mod;
        }
        printf("%lld\n",num[n]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值