PAT甲级1125解题报告

49 篇文章 0 订阅

好几天没做了已经。。感觉有点变难了,这几天也比较忙就一天一题吧,挑了半天挑了道会做了。

1125 Chain the Ropes (25 point(s))

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

rope.jpg

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤10​4​​). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 10​4​​.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

题目大意:给一堆绳子,给出他们的长度,求一个最大的长度不大于他最长绳子的长度,绳子可以对接,但对接的话他们的长度都要对折。

解题思路:常识吧,任意两数相加的平均数小于等于这两者的最大值,所以就排个序从最短的一直对折到最后一根,结果可以证明比最长的那根小,这样得到的也就是最长了。

#include<iostream>
#include<string.h>
#include<vector>
#include<algorithm>
#include<iomanip>
#include<time.h>
#include<math.h>
#include<set>
#include<list>
#include<climits>
#include<queue>
#include<cstring>
#include<map>
#include<stack>
#include<string>
using namespace std;
vector<int> a;
int main()
{
	int N;
	scanf("%d", &N);
	for (int i = 0; i < N; i++) {
		int tmp;
		scanf("%d", &tmp);
		a.push_back(tmp);
	}
	if (a.size() == 1) {
		printf("%d\n", a[0]);
	}
	else {
		sort(a.begin(), a.end());
		double res = 0;
		res = a[0];
		for (int i = 1; i < a.size(); i++) {
			res =(res+ a[i])/2;
		}
		int t = res;
		printf("%d\n", t);
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值