HDU 4970 Killing Monsters

129 篇文章 0 订阅
37 篇文章 0 订阅

Killing Monsters

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1041    Accepted Submission(s): 498

 

Problem Description

Kingdom Rush is a popular TD game, in which you should build some towers to protect your kingdom from monsters. And now another wave of monsters is coming and you need again to know whether you can get through it.

The path of monsters is a straight line, and there are N blocks on it (numbered from 1 to N continuously). Before enemies come, you have M towers built. Each tower has an attack range [L, R], meaning that it can attack all enemies in every block i, where L<=i<=R. Once a monster steps into block i, every tower whose attack range include block i will attack the monster once and only once. For example, a tower with attack range [1, 3] will attack a monster three times if the monster is alive, one in block 1, another in block 2 and the last in block 3.

A witch helps your enemies and makes every monster has its own place of appearance (the ith monster appears at block Xi). All monsters go straightly to block N.

Now that you know each monster has HP Hi and each tower has a value of attack Di, one attack will cause Di damage (decrease HP by Di). If the HP of a monster is decreased to 0 or below 0, it will die and disappear.
Your task is to calculate the number of monsters surviving from your towers so as to make a plan B.

 

 

Input

The input contains multiple test cases.

The first line of each case is an integer N (0 < N <= 100000), the number of blocks in the path. The second line is an integer M (0 < M <= 100000), the number of towers you have. The next M lines each contain three numbers, Li, Ri, Di (1 <= Li <= Ri <= N, 0 < Di <= 1000), indicating the attack range [L, R] and the value of attack D of the ith tower. The next line is an integer K (0 < K <= 100000), the number of coming monsters. The following K lines each contain two integers Hi and Xi (0 < Hi <= 10^18, 1 <= Xi <= N) indicating the ith monster’s live point and the number of the block where the ith monster appears.

The input is terminated by N = 0.

 

 

Output

Output one line containing the number of surviving monsters.

 

 

Sample Input

 

5 2 1 3 1 5 5 2 5 1 3 3 1 5 2 7 3 9 1 0

 

 

Sample Output

 

3

Hint

In the sample, three monsters with origin HP 5, 7 and 9 will survive.

 

 

Author

SYSU

 

 

Source

2014 Multi-University Training Contest 9


题目链接  :http://acm.hdu.edu.cn/showproblem.php?pid=4970


题目大意  :有n个格子在一条线标号1-n上,可以给范围在l到r内的格子架上攻击力为d的攻击塔,有m个怪物,每个怪物有个血量h和出生地x,现在要求有多少怪物可以活着走到第n个塔后,怪物每走一步就会被所在格子的塔(如果有)攻击。


题目分析  :线段树可做,但是麻烦因为剪不好超时,剪的好也只能压时间过,本题其实是水题只需要离线计算出到每个格子的累计伤害即可
 

#include <cstdio>
#include <cstring>
int const MAX = 100000 + 5;
long long a[MAX];
int main()
{
    int n;
    int ans;
    while(scanf("%d",&n) != EOF && n)
    {
        ans = 0;
        int m, l, r, d;
        memset(a, 0, sizeof(a));
        scanf("%d",&m);
        for(int i = 0; i < m; i++)
        {
            scanf("%d %d %d", &l, &r, &d);
            a[l] += d;
            a[r + 1] -= d;
        }
        //计算每点的攻击力
        for(int i = 1; i <= n; i++)
            a[i] += a[i - 1];
        //计算到每点的累加攻击力
        for(int i = 1; i <= n; i++)
            a[i] += a[i - 1];
        int k, pos;
        long long hp;
        scanf("%d",&k);
        while(k--)
        {
            scanf("%I64d %d", &hp, &pos);
            if(a[n] - a[pos - 1] < hp)
                ans++;
        }
        printf("%d\n",ans);
    }   
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值