HDU 4762 Cut the Cake

Cut the Cake

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 889    Accepted Submission(s): 436



Problem Description
MMM got a big big big cake, and invited all her M friends to eat the cake together. Surprisingly one of her friends HZ took some (N) strawberries which MMM likes very much to decorate the cake (of course they also eat strawberries, not just for decoration). HZ is in charge of the decoration, and he thinks that it's not a big deal that he put the strawberries on the cake randomly one by one. After that, MMM would cut the cake into M pieces of sector with equal size and shape (the last one came to the party will have no cake to eat), and choose one piece first. MMM wants to know the probability that she can get all N strawberries, can you help her? As the cake is so big, all strawberries on it could be treat as points.
 

Input
First line is the integer T, which means there are T cases.
For each case, two integers M, N indicate the number of her friends and the number of strawberry.
(2 < M, N <= 20, T <= 400)
 

Output
As the probability could be very small, you should output the probability in the form of a fraction in lowest terms. For each case, output the probability in a single line. Please see the sample for more details.
 

Sample Input
  
  
2 3 3 3 4
 

Sample Output
  
  
1/3 4/27
 

Source
2013 ACM/ICPC Asia Regional Changchun Online


题目链接 :http://acm.hdu.edu.cn/showproblem.php?pid=4762

题目大意 :M个人分蛋糕,N个草莓随机分布在蛋糕上,把蛋糕平均分并优先选择一块,求你能拿到所有草莓的概率。

题目分析 :取最外面的一个草莓为第一刀切的位置,这样一共有N种方案,然后剩下N-1个草莓,每个的概率为1/M.所以概率为N / M ^ (N - 1)要求化简输出。

代码:
import java.util.Scanner;
import java.math.*;
public class Main
{
    static Scanner in = new Scanner(System.in);
    public static void main(String args[])
    {
        int ca;
        BigInteger n, m, tmp;
        ca = in.nextInt();
        while(ca-- != 0)
        {
            m = in.nextBigInteger();
            n = in.nextBigInteger();
            m = m.pow(n.intValue() - 1);
            tmp = m.gcd(n);
            System.out.println(n.divide(tmp) + "/" + m.divide(tmp));
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值