POJ 1948 Triangular Pastures (线性dp)

Triangular Pastures
Time Limit: 1000MS
Memory Limit: 30000K
Total Submissions: 6689
Accepted: 2180

Description

Like everyone, cows enjoy variety. Their current fancy is new shapes for pastures. The old rectangular shapes are out of favor; new geometries are the favorite.

I. M. Hei, the lead cow pasture architect, is in charge of creating a triangular pasture surrounded by nice white fence rails. She is supplied with N (3 <= N <= 40) fence segments (each of integer length Li (1 <= Li <= 40) and must arrange them into a triangular pasture with the largest grazing area. Ms. Hei must use all the rails to create three sides of non-zero length.

Help Ms. Hei convince the rest of the herd that plenty of grazing land will be available.Calculate the largest area that may be enclosed with a supplied set of fence segments.

Input

* Line 1: A single integer N

* Lines 2..N+1: N lines, each with a single integer representing one fence segment's length. The lengths are not necessarily unique.

Output

A single line with the integer that is the truncated integer representation of the largest possible enclosed area multiplied by 100. Output -1 if no triangle of positive area may be constructed.

Sample Input

5
1
1
3
3
4

Sample Output

692

Hint

[which is 100x the area of an equilateral triangle with side length 4]

Source

USACO 2002 February


题目链接:http://poj.org/problem?id=1948

题目大意:输入一个数n,然后输入n个数字,用这n个数字组成三角形的三边,使得三角形的面积最大,求最大面积*100


题目分析:先dp判断能组成三角形的所有情况,dp[i][j]记录i, j, tot - i - j能组成三角形的情况,然后暴搜最大的情况,三角形面积用海伦公式求

p = (a + b + c) *1.0 / 2

s = 100 * sqrt(p * (p - a) * (p - b) * (p - c));


#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;

int area(int a, int b, int c)
{
    double p = (a + b + c) * 1.0 / 2;
    int s = (int)100 * sqrt(p * (p - a) * (p - b) * (p - c));
    return s;
}

int main()
{
    int n, l[45], dp[1000][1000], tot = 0, ans = -1;
    memset(dp, 0, sizeof(dp));
    scanf("%d", &n);
    for(int i = 0; i < n; i++)
    {
        scanf("%d", &l[i]);
        tot += l[i];
    }
    dp[0][0] = 1;
    for(int i = 0; i < n; i++)
        for(int j = tot; j >= 0; j--)
            for(int k = j; k >= 0; k--)
                if( (j >= l[i] && dp[j - l[i]][k]) || (k >= l[i] && dp[j][k - l[i]]))
                    dp[j][k] = 1;
    for(int i = tot; i > 0; i--)
    {
        for(int j = i; j > 0; j--)
        {
            if(dp[i][j])
            {
                int k = tot - i - j;
                ans = max(ans, area(i, j, k));
            }
        }
    }
    printf("%d\n", ans);
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值