POJ 2513 Colored Sticks (Trie树+并查集+欧拉路)

129 篇文章 0 订阅
91 篇文章 1 订阅


Colored Sticks
Time Limit: 5000MS Memory Limit: 128000K
Total Submissions: 31490 Accepted: 8320

Description

You are given a bunch of wooden sticks. Each endpoint of each stick is colored with some color. Is it possible to align the sticks in a straight line such that the colors of the endpoints that touch are of the same color?

Input

Input is a sequence of lines, each line contains two words, separated by spaces, giving the colors of the endpoints of one stick. A word is a sequence of lowercase letters no longer than 10 characters. There is no more than 250000 sticks.

Output

If the sticks can be aligned in the desired way, output a single line saying Possible, otherwise output Impossible.

Sample Input

blue red
red violet
cyan blue
blue magenta
magenta cyan

Sample Output

Possible

Hint

Huge input,scanf is recommended.

Source

The UofA Local 2000.10.14

题目链接:http://poj.org/problem?id=2513

题目大意:给一些木棍,两端都有颜色,只有两根对应的端点颜色相同才能相接,问能不能把它们接成一根木棍

题目分析:题意不难,典型的无向图判断是否存在欧拉通路或回路的问题,但是字符串太多,用map超时,这里使用Trie树给每个木棍标号,判断是否存在欧拉通路或回路抓住两点就行了,第一是图连通,第二是奇数度结点只能有0个(回路)或2个(通路)


#include <cstdio>
#include <cstring>
int const MAX = 500005;
int fa[MAX], d[MAX], cnt;

struct Trie
{
    int sz, t[MAX][15];
    int jud[MAX];
    Trie()
    {
        sz = 1;
        memset(t[0], -1, sizeof(t));
        jud[0] = 0;
    }
    void clear()
    {
        sz = 1;
        memset(t[0], -1, sizeof(t));
        jud[0] = 0;
    }
    int idx(char c)
    {
        return c - 'a';
    }
    void insert(char* s, int v)
    {
        int u = 0, len = strlen(s);
        for(int i = 0; i < len; i++)
        {
            int c = idx(s[i]);
            if(t[u][c] == -1)
            {
                memset(t[sz], -1, sizeof(t[sz]));
                jud[sz] = 0;
                t[u][c] = sz++;
            }
            u = t[u][c];
        }
        jud[u] = v;
    }
    int search(char* s)
    {
        int u = 0, len = strlen(s);
        for(int i = 0; i < len; i++)
        {
            int c = idx(s[i]);
            if(t[u][c] == -1) 
                return -1;
            u = t[u][c];
        }
        if(jud[u]) 
            return jud[u];
        return -1;
    }
}t;


void Init()
{
    for(int i = 0; i < MAX; i++)
        fa[i] = i;
}

int Find(int x)
{
    return x == fa[x] ? x : fa[x] = Find(fa[x]);
}

void Union(int a, int b)
{
    int r1 = Find(a);
    int r2 = Find(b);
    if(r1 != r2)
        fa[r1] = r2;
}

bool eluer()
{
    int sum = 0, t = -1;
    for(int i = 1; i < cnt; i++)
        if(d[i] % 2) 
            sum++;
    if(sum != 0 && sum != 2)
        return false;
    for(int i = 1; i < cnt; i++)
    {
        if(t == -1)
            t = Find(i);
        else if(Find(i) != Find(t)) 
            return false;
    }
    return true;
}

int main()
{
    char s1[20],s2[20];
    cnt = 1;
    Init();
    t.clear();
    while(scanf("%s %s", s1, s2) != EOF)
    {
        if(t.search(s1) == -1)
            t.insert(s1, cnt++);
        int u = t.search(s1);
        if(t.search(s2) == -1)
            t.insert(s2, cnt++);
        int v = t.search(s2);
        Union(u, v);
        d[u]++;
        d[v]++;
    }
    if(eluer())
        printf("Possible\n");
    else
        printf("Impossible\n");
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值