HDU 1299 Diophantus of Alexandria (公式变形 分解质因数)

78 篇文章 0 订阅


Diophantus of Alexandria

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2931    Accepted Submission(s): 1132

Problem Description
Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are commonly called diophantine equations. One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat's last theorem) was found only recently by Andrew Wiles.
Consider the following diophantine equation:

1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)

Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions:

1 / 5 + 1 / 20 = 1 / 4
1 / 6 + 1 / 12 = 1 / 4
1 / 8 + 1 / 8 = 1 / 4

Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly?
 
Input
The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9).
 
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given value of n. Terminate each scenario with a blank line.
 
Sample Input
  
  
2 4 1260
 
Sample Output
  
  
Scenario #1: 3 Scenario #2: 113
 
Source
TUD Programming Contest 2006

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1299

题目大意:给出n,求满足1/x + 1/y = 1/n的(x,y)的对数,(x,y)与(y,x)属于同一种

题目分析:1/x + 1/y = 1/n => xy - nx - ny = 0 => n^2 + xy - nx - ny = n^2 => (n - x)(n - y) = n^2,问题转化为求n^2的因子数,由唯一分解定理可以得到:设p1,p2...pk为n的质因子a1,a2...ak,为质因子的幂,则n^2因子数为(2*a1 + 1)*(2*a2 + 1)*...*(2*ak + 1),注意当n为质数时根据公式要乘3,考虑去掉重复的最后答案除2加1
#include <cstdio>
#define ll long long
int const MAX = 4e5 + 5;
int p[MAX], pfac[MAX];
bool noprime[MAX];
int pnum, pfacnum, n;
ll ans;

void get_prime()
{
    pnum = 0;
    for(int i = 2; i < MAX; i++)
    {
        if(!noprime[i])
            p[pnum ++] = i;
        for(int j = 0; j < pnum && i * p[j] < MAX; j++)
        {
            noprime[i * p[j]] = true;
            if(i % p[j] == 0)
                break;
        }
    }
}

void get_pfac()
{
    pfacnum = 0;
    for(int i = 2; i * i <= n; i++)
    {
        int cnt = 0;
        if(n % i == 0)
        {
            pfac[pfacnum ++] = i;
            while(n % i == 0)
            {
                cnt ++;
                n /= i;
            }
        }
        if(cnt)
            ans *= (ll) (2 * cnt + 1);
    }
}

int main()
{
    get_prime();
    int T;
    scanf("%d", &T);
    for(int ca = 1; ca <= T; ca++)
    {
        ans = 1;
        scanf("%d", &n);
        get_pfac();
        if(n > 1)
            ans *= 3ll;
        printf("Scenario #%d:\n%I64d\n\n", ca, (ans + 1) >> 1);
    }
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值