ZOJ 1610 Count the Colors (线段树区间更新)

Count the Colors

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Painting some colored segments on a line, some previously painted segments may be covered by some the subsequent ones.

Your task is counting the segments of different colors you can see at last.


Input

The first line of each data set contains exactly one integer n, 1 <= n <= 8000, equal to the number of colored segments.

Each of the following n lines consists of exactly 3 nonnegative integers separated by single spaces:

x1 x2 c

x1 and x2 indicate the left endpoint and right endpoint of the segment, c indicates the color of the segment.

All the numbers are in the range [0, 8000], and they are all integers.

Input may contain several data set, process to the end of file.


Output

Each line of the output should contain a color index that can be seen from the top, following the count of the segments of this color, they should be printed according to the color index.

If some color can't be seen, you shouldn't print it.

Print a blank line after every dataset.


Sample Input

5
0 4 4
0 3 1
3 4 2
0 2 2
0 2 3
4
0 1 1
3 4 1
1 3 2
1 3 1
6
0 1 0
1 2 1
2 3 1
1 2 0
2 3 0
1 2 1


Sample Output

1 1
2 1
3 1

1 1

0 2
1 1



Author:  Standlove

Source: ZOJ Monthly, May 2003


题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=610


题目大意:一共要给n条线段上色,颜色用数字表示且会覆盖,问没种颜色有多少段,如果没有的话不用输出


题目分析:注意n是n条线段而不是总的线段长,因为是给线上色不是给点上色,画个图就能看出来Update的时候左端点直接加1避免变成给点上色,这题其实不需要lazy数组,直接用结点的颜色信息就可以充当lazy用

#include <cstdio>
#include <cstring>
#include <algorithm>
#define lson l, mid, rt << 1
#define rson mid + 1, r, rt << 1 | 1
using namespace std;
int const MAX = 8005;
int const CON = 8000;
int col[MAX << 2], num[MAX];
int getcol[MAX], n;

void Build()
{
	memset(num, 0, sizeof(num));
	memset(col, -1, sizeof(col));
	memset(getcol, -1, sizeof(getcol));
}

void PushDown(int rt)
{
	if(col[rt] != -1)
	{
		col[rt << 1] = col[rt];
		col[rt << 1 | 1] = col[rt];
		col[rt] = -1;
	}
	return;
}

void Update(int L, int R, int c, int l, int r, int rt)
{
	if(L <= l && r <= R)
	{
		col[rt] = c;
		return;
	}
	int mid = (l + r) >> 1;
	PushDown(rt);
	if(L <= mid)
		Update(L, R, c, lson);
	if(mid < R)
		Update(L, R, c, rson);
	return;
}

void Query(int l, int r, int rt)
{
	if(col[rt] != -1)
	{
		for(int i = l; i <= r; i++)
			getcol[i] = col[rt];
		return;
	}
	if(l < r && col[rt] == -1)
	{
		int mid = (l + r) >> 1;
		Query(lson);
		Query(rson);
	}
	return;
}

void Solve()
{
	if(getcol[0] != -1)
		num[getcol[0]] ++;
	for(int i = 1; i <= CON; i++)
		if(getcol[i] != -1 && getcol[i] != getcol[i - 1])
			num[getcol[i]] ++;
	for(int i = 0; i <= CON; i++)
		if(num[i])
			printf("%d %d\n", i, num[i]);
	printf("\n");
}

int main()
{
	while(scanf("%d", &n) != EOF)
	{
		Build();
		for(int i = 0; i < n; i++)
		{
			int l, r, c;
			scanf("%d %d %d", &l, &r, &c);
			Update(l + 1, r, c, 1, CON, 1);
		}
		Query(1, CON, 1);
		Solve();
	}
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值