L2-012 关于堆的判断

L2-012 关于堆的判断 (25 分)

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T

 

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<iostream>
#include<string>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<vector>
using namespace std;
#define inf 0x3f3f3f3f
#define LL long long
int v[2005];
int main()
{
	memset(v,0x3f,sizeof v);
	int n,m,i,j,p; 
	scanf("%d%d",&n,&m);
	for(i=1;i<=n;i++)
	scanf("%d",&v[i]);
	for(i=2;i<=n;i++)
	{//建堆 
		int j=i;
		while(j>1)
		{
			if(v[j]<v[j/2])swap(v[j],v[j/2]);
			j=j/2;
		}
	}
	//for(i=1;i<=n;i++) printf("%d ",v[i]);
	while(m--)
	{
		int a,b,f=0,x,y;
		char c[150];
		scanf("%d",&a);
		scanf("%s",c);
		if(c[0]=='a')
		{//a and b are siblings
			scanf("%d",&b);
			scanf("%s",c);
			scanf("%s",c);
			for(i=1;i<=n;i++)
			{
				if(v[i]==a)
				x=i;
				if(v[i]==b)
				y=i;
			}
			if(x!=y&&x/2==y/2)f=0;
			else f=1;
		}
		else
		{
			scanf("%s",c);
			if(c[0]=='a')
			{//a is a child of b
				scanf("%s",c);
				scanf("%s",c);
				scanf("%d",&b);
				for(i=1;i<=n;i++)
				{
					if(v[i]==a)
					x=i;
					if(v[i]==b)
					y=i;
				}
				if(x!=y&&(y*2==x||y*2+1==x)) f=0;
				else f=1;
			}
			else
			{
				scanf("%s",c);
				if(c[0]=='r')
				{//a is the root
					if(v[1]==a) f=0;
					else f=1;
				}
				else
				{//a is the parent of b
					scanf("%s",c);
					scanf("%d",&b);
					for(i=1;i<=n;i++)
					{
						if(v[i]==a)
						x=i;
						if(v[i]==b)
						y=i;
					}
					if(x!=y&&(x*2==y||x*2+1==y)) f=0;
					else f=1;
				}
			}
		}
		if(f)printf("F\n");
		else printf("T\n");
	}
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值