1091 Acute Stroke (30 分) 三维广搜bfs

One important factor to identify acute stroke (急性脑卒中) is the volume of the stroke core. Given the results of image analysis in which the core regions are identified in each MRI slice, your job is to calculate the volume of the stroke core.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive integers: M, N, L and T, where M and N are the sizes of each slice (i.e. pixels of a slice are in an M×N matrix, and the maximum resolution is 1286 by 128); L (≤60) is the number of slices of a brain; and T is the integer threshold (i.e. if the volume of a connected core is less than T, then that core must not be counted).

Then L slices are given. Each slice is represented by an M×N matrix of 0's and 1's, where 1 represents a pixel of stroke, and 0 means normal. Since the thickness of a slice is a constant, we only have to count the number of 1's to obtain the volume. However, there might be several separated core regions in a brain, and only those with their volumes no less than T are counted. Two pixels are connected and hence belong to the same region if they share a common side, as shown by Figure 1 where all the 6 red pixels are connected to the blue one.

figstroke.jpg

Figure 1

Output Specification:

For each case, output in a line the total volume of the stroke core.

Sample Input:

3 4 5 2
1 1 1 1
1 1 1 1
1 1 1 1
0 0 1 1
0 0 1 1
0 0 1 1
1 0 1 1
0 1 0 0
0 0 0 0
1 0 1 1
0 0 0 0
0 0 0 0
0 0 0 1
0 0 0 1
1 0 0 0

Sample Output:

26

 读题读了半年5555

一开始开了ma[1300][150][100]内存超限了555小气鬼

题意&思路:输入n,m,l,t,表示n*m*l的立方体,找总的联通的个数,其中小联通块中个数要>=t

输入立方体时候要注意l是最外层,然后是n,m,之后6个方向bfs,当联通个数cnt>=t时候加到总的ans中

#include <stdio.h>
#include <string.h>
#include <string>
#include <map>
#include <queue>
#include <algorithm>
#include <iostream>
#define INF 0x3f3f3f3f
using namespace std;
int ma[1300][130][65];
int vis[1300][130][65];
int m,n,l,t,ans;
int dx[6]={1,0,0,-1,0,0};
int dy[6]={0,1,0,0,-1,0};
int dz[6]={0,0,1,0,0,-1};
struct node
{
	int x,y,z;
}p;
bool judge(int x,int y,int z)
{//判断是否越界 
	if(x<0||x>=n)return 0;
	if(y<0||y>=m)return 0;
	if(z<0||z>=l)return 0;
	return 1;
}
void bfs(int x,int y,int z)
{
	int cnt=0,i;
	p.x=x;p.y=y;p.z=z;
	vis[x][y][z]=1;
	queue<node> q;
	q.push(p);
	while(!q.empty())
	{
		node u=q.front();
		q.pop();
		cnt++;
		for(i=0;i<6;i++)
		{
			int xx=u.x+dx[i];
			int yy=u.y+dy[i];
			int zz=u.z+dz[i];
			if(judge(xx,yy,zz)&&!vis[xx][yy][zz]&&ma[xx][yy][zz])
			{
				vis[xx][yy][zz]=1;
				p.x=xx;p.y=yy;p.z=zz;
				q.push(p);
			}
		}
	}
	if(cnt>=t)
	ans+=cnt;
}
int main()
{
	int i,j,k;
	ans=0;
	scanf("%d%d%d%d",&n,&m,&l,&t);
	memset(vis,0,sizeof vis);	
	for(i=0;i<l;i++)
	{
		for(j=0;j<n;j++)
		{
			for(k=0;k<m;k++)
			scanf("%d",&ma[j][k][i]);
		}
	} 
	for(i=0;i<l;i++)
	{
		for(j=0;j<n;j++)
		{
			for(k=0;k<m;k++)
			{
				if(ma[j][k][i]&&!vis[j][k][i])
				bfs(j,k,i);
			}
		}
	} 
	printf("%d\n",ans);
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值