1099 Build A Binary Search Tree (30 分) BST 中序遍历构造树然后输出层次遍历

1099 Build A Binary Search Tree (30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.

figBST.jpg

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100) which is the total number of nodes in the tree. The next Nlines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N−1, and 0 is always the root. If one child is missing, then −1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

 给定一棵固定位置的BST,然后插入一组序列。

因为BST的中序遍历就是从小到大的排序,所以借此可以还原这棵树。

然后输出层次遍历。

#include <stdio.h>
#include <string.h>
#include <string>
#include <map>
#include <queue>
#include <math.h>
#include <algorithm>
#include <iostream>
#define INF 0x3f3f3f3f
using namespace std;
struct Node
{
	int val;
	int l,r;
}tree[105];
int a[105],p;
void Inorder(int x)
{//中序遍历建立BST 
	if(tree[x].l!=-1) Inorder(tree[x].l);
	tree[x].val=a[p++];
	if(tree[x].r!=-1) Inorder(tree[x].r);
}	
int main()
{
	int n,i,j;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	scanf("%d%d",&tree[i].l,&tree[i].r);
	for(i=0;i<n;i++)
	scanf("%d",&a[i]);
	sort(a,a+n);
	p=0;
	Inorder(0);
	//层次遍历 
	vector<int> v;
	queue<Node> q;
	q.push(tree[0]);
	while(!q.empty())
 	{
 		Node u=q.front();
 		q.pop();
 		v.push_back(u.val);
 		if(u.l!=-1)
 		q.push(tree[u.l]);
 		if(u.r!=-1)
 		q.push(tree[u.r]);
 	}
 	for(i=0;i<v.size()-1;i++)
 	printf("%d ",v[i]);
 	printf("%d\n",v[v.size()-1]);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值