1098 Insertion or Heap Sort (25 分) 插入排序or堆排序

1098 Insertion or Heap Sort (25 分)

According to Wikipedia:

Insertion sort iterates, consuming one input element each repetition, and growing a sorted output list. Each iteration, insertion sort removes one element from the input data, finds the location it belongs within the sorted list, and inserts it there. It repeats until no input elements remain.

Heap sort divides its input into a sorted and an unsorted region, and it iteratively shrinks the unsorted region by extracting the largest element and moving that to the sorted region. it involves the use of a heap data structure rather than a linear-time search to find the maximum.

Now given the initial sequence of integers, together with a sequence which is a result of several iterations of some sorting method, can you tell which sorting method we are using?

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then in the next line, N integers are given as the initial sequence. The last line contains the partially sorted sequence of the N numbers. It is assumed that the target sequence is always ascending. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in the first line either "Insertion Sort" or "Heap Sort" to indicate the method used to obtain the partial result. Then run this method for one more iteration and output in the second line the resulting sequence. It is guaranteed that the answer is unique for each test case. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

10
3 1 2 8 7 5 9 4 6 0
1 2 3 7 8 5 9 4 6 0

Sample Output 1:

Insertion Sort
1 2 3 5 7 8 9 4 6 0

Sample Input 2:

10
3 1 2 8 7 5 9 4 6 0
6 4 5 1 0 3 2 7 8 9

Sample Output 2:

Heap Sort
5 4 3 1 0 2 6 7 8 9

题意:给定一个序列,判断这个序列是插入排序or堆排序的过程序列

判断输出排序方法后,输出该排序的下一个序列。

思路:插入排序的过程序列特点比较明显:前k个数有序,后n-k个数与原序列相同。

可依此来判断排序方法。

#include <stdio.h>
#include <string.h>
#include <string>
#include <map>
#include <vector>
#include <queue>
#include <math.h>
#include <algorithm>
#include <iostream>
#define INF 0x3f3f3f3f
using namespace std;
int a[105],b[105];
void downAdjust(int low,int high) 
{
	int i=1,j=i*2;//i欲调整结点,j左孩子结点 
	while(j<=high) 
	{
		if(j+1<=high&&b[j]<b[j+1]) j++;
		if(b[i]> b[j]) break;
		swap(b[i],b[j]);
		i=j; 
		j*=2;
	}
}
int main() 
{
	int n,i,j,k,p;
	scanf("%d",&n);
	for(i=1;i<=n;i++)
	scanf("%d",&a[i]);
	for(i=1;i<=n;i++)
	scanf("%d",&b[i]);
	//判断是否为插入排序:前k个递增,n-k个与原序列相同 
	k=1;
	while(k<=n&&b[k-1]<=b[k])k++;
	p=k;
	while(k<=n&&a[k]==b[k])k++;
	if(k==n+1)
	{
		printf("Insertion Sort\n");
		sort(b+1,b+p+1);//多插入一个,即前p个有序 
	} 
	else
	{
		printf("Heap Sort\n");
		k=n;
		while(k>2&&b[k]>=b[2])k--;
		swap(b[1],b[k]);
		downAdjust(1,k-1);
	}
	for(i=1;i<=n;i++)
	{
		if(i!=1) printf(" ");
		printf("%d",b[i]);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值