H - An easy problem 线段树

 

One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation. 
1. multiply X with a number. 
2. divide X with a number which was multiplied before. 
After each operation, please output the number X modulo M. 

Input

The first line is an integer T(1≤T≤101≤T≤10), indicating the number of test cases. 
For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. (1≤Q≤105,1≤M≤1091≤Q≤105,1≤M≤109) 
The next Q lines, each line starts with an integer x indicating the type of operation. 
if x is 1, an integer y is given, indicating the number to multiply. (0<y≤1090<y≤109) 
if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.) 

It's guaranteed that in type 2 operation, there won't be two same n. 

Output

For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1. 
Then Q lines follow, each line please output an answer showed by the calculator. 

Sample Input

1
10 1000000000
1 2
2 1
1 2
1 10
2 3
2 4
1 6
1 7
1 12
2 7

Sample Output

Case #1:
2
1
2
20
10
1
6
42
504
84
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
#define ll long long
#define LL(x) (x<<1)
#define RR(x) (x<<1|1)
#define MID(a,b) (a+((b-a)>>1))
const int N=1e5+2;

struct node
{
	int lft,rht;
	ll sum;
	int mid(){return MID(lft,rht);}
};

ll yy[N],n, mod, t, x, y, k;

struct Segtree
{
	node tree[N*4];
	void build(int lft,int rht,int ind)
	{
		tree[ind].lft=lft;	tree[ind].rht=rht;
		tree[ind].sum=1;
		if(lft==rht) tree[ind].sum=yy[lft];
		else
		{
			int mid=tree[ind].mid();
			build(lft,mid,LL(ind));
			build(mid+1,rht,RR(ind));
			tree[ind].sum=(tree[LL(ind)].sum*tree[RR(ind)].sum)%mod;
		}
	}
	void updata(int pos,int ind,ll valu)
	{
		if(tree[ind].lft==tree[ind].rht) tree[ind].sum=valu;
		else
		{
			int mid=tree[ind].mid();
			if(pos<=mid) updata(pos,LL(ind),valu);
			else updata(pos,RR(ind),valu);
			tree[ind].sum=1LL*tree[LL(ind)].sum*tree[RR(ind)].sum%mod;
		}
	}
	ll query(int st,int ed,int ind)
	{
		int lft=tree[ind].lft,rht=tree[ind].rht;
		if(st<=lft&&rht<=ed) return tree[ind].sum;
		else
		{
			int mid=tree[ind].mid();
			ll sum1=1,sum2=1;
			if(st<=mid) sum1=query(st,ed,LL(ind));
			if(ed>mid) sum2=query(st,ed,RR(ind));
			return sum1*sum2%mod;
		}
	}
}seg;
int main()
{
	scanf("%lld", &t);
	while(t--){
		scanf("%lld%lld", &n, &mod);
		for(int i=1;i<=n;++i)yy[i]=1;
		seg.build(1,n, 1);

		printf("Case #%lld:\n", ++k);
		for(int i=1;i<=n;++i){
			scanf("%lld%lld", &x, &y);
			if(x==1){
				seg.updata(i,1,y);
			}else{
				seg.updata(y, 1, 1);
			}
			printf("%lld\n", seg.query(1, n, 1));
		}
	}
	return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值