UVa OJ 1608 - Non-boring sequences

UVa OJ 1608 - Non-boring sequences

Problem

A sequence is called non-boring if its every connected subsequence contains a unique element, i.e. an element such that no other element of that subsequence has the same value.
  Given a sequence of integers, decide whether it is non-boring.

Input

The first line of the input contains the number of test cases T. The descriptions of the test cases follow:
  Each test case starts with an integer n (1 ≤ n ≤ 200000) denoting the length of the sequence. In the next line the n elements of the sequence follow, separated with single spaces. The elements are non-negative integers less than 109.

Output

Print the answers to the test cases in the order in which they appear in the input. For each test case print a single line containing the word ‘non-boring’ or ‘boring’.

Sample Input

4
5
1 2 3 4 5
5
1 1 1 1 1
5
1 2 3 2 1
5
1 1 2 1 1

Sample Output

non-boring
boring
non-boring
boring

Solution

先找出每个点离它最近的相同点,然后递归,利用分治法从两边向中间搜索,如果有区间的点都能在该区间内找到重复点,那么就表示这个序列是无聊的。

#include <iostream>
#include <map>
using namespace std;

const int maxn = 200001;
int cas, n;
int x[maxn], l[maxn], r[maxn];

bool ite(int ll, int rr) {
    if (ll >= rr) return true;
    for (int i=ll, j=rr; i<=j; ++i,--j) {
        if (l[i] < ll && r[i] > rr)
            return (ite(ll, i-1) && ite(i+1, rr));
        if (l[j] < ll && r[j] > rr)
            return (ite(ll, j-1) && ite(j+1, rr));
    }
    return false;
}

int main() {
    ios::sync_with_stdio(false);
    cin.tie(0);

    cin >> cas;
    while (cas--){
        cin >> n;
        for (int i = 0; i < n; ++i)
            cin >> x[i];
        map<int, int> m;
        for (int i = 0; i < n; ++i) {
            if (!m.count(x[i])) l[i] = -1;
            else l[i] = m[x[i]];
            m[x[i]] = i;
        }
        m.clear();
        for (int i = n - 1; i > -1; --i) {
            if (!m.count(x[i])) r[i] = n;
            else r[i] = m[x[i]];
            m[x[i]] = i;
        }
        if (ite(0, n - 1)) cout << "non-boring";
        else cout << "boring";
        cout << '\n';
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值