UVa OJ 12265 - Selling Land

UVa OJ 12265 - Selling Land

Problem

输入一个n*m(1≤n,m≤1000)矩阵,每个格子可能是空地,也可能是沼泽。对于每个空地格子,求出以它为右下角的空矩形的最大周长,然后统计每个周长出现了多少次。

Input

On the first line a positive integer: the number of test cases, at most 100. After that per test case:

  • One line with two integers n and m (1 ≤ n, m ≤ 1000): the dimensions of Per’s parcel.
  • n lines, each with m characters. Each character is either ‘#’ or ‘.’. The j-th character on the i-th line is a ‘#’ if position (i, j) is a swamp, and ‘.’ if it is grass. The north-west corner of Per’s parcel has coordinates (1, 1), and the south-east corner has coordinates (n, m).

Output

Zero or more lines containing a complete list of how many parcels of each perimeter Per needs to sell in order to maximize his profit. More specifically, if Per should sell pi parcels of perimeter i in the optimal solution, output a single line ‘pixi’. The lines should be sorted in increasing order of i. No two lines should have the same value of i, and you should not output lines with pi = 0.

Sample Input

1
6 5
..#.#
.#...
#..##
...#.
#....
#..#.

Sample Output

6 x 4
5 x 6
5 x 8
3 x 10
1 x 12

Solution

My code is inefficient, it takes about 2s to run.

The main idea is to handle the problem is creating arrays or whatever to record the length(height) of each blocks. And then caculate the circumference of them.

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int maxn = 1005;
int cas, n, m, maxCircum, minLength;
char land[maxn][maxn];
int landLen[maxn][maxn], idx[maxn << 2];

int main() {
    ios::sync_with_stdio(false);
    cin.tie(0);
    //freopen("input.txt" , "r", stdin );
    //freopen("output.txt", "w", stdout);
    cin >> cas;
    while(cas--) {
        memset(idx, 0, sizeof(idx));
        maxCircum = 0;
        cin >> n >> m;
        for (int i = 1; i <= n; ++i) cin >> land[i]+1;
        for (int i = 1; i <= n; ++i) {
            for (int j = 1; j <= m; ++j) {
                if (land[i][j] != '#')
                    landLen[i][j] = landLen[i-1][j] + 1;
                else landLen[i][j] = 0;
            }
        }
        for (int i = n; i > 0; --i) {
            for (int j = m; j > 0; --j) {
                if (landLen[i][j]) {
                    int Max = (landLen[i][j]+1) << 1;
                    minLength = landLen[i][j];
                    for (int k = j-1; k > 0 && landLen[i][k]; --k) {
                        minLength = min(minLength, landLen[i][k]);
                        int tmp = j-k+1+minLength << 1;
                        Max = max(Max, tmp);
                    }
                    ++idx[Max];
                    maxCircum = max(Max, maxCircum);
                }
            }
        }
        for (int i = 4; i <= maxCircum; ++i)
            if (idx[i])
                printf("%d x %d\n", idx[i], i);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
杭州电子科技大学在线评测系统(杭电OJ)中的题目1000-1100是一系列编程题,我将分别进行回答。 1000题是一个简单的入门题,要求计算两个整数的和。我们可以使用一个简单的算法,读取输入的两个整数,然后将它们相加,最后输出结果即可。 1001题是一个稍微复杂一些的题目,要求实现字符串的逆序输出。我们可以使用一个循环来逐个读取输入的字符,然后将这些字符存储在一个数组中。最后,我们可以倒序遍历数组并将字符依次输出,实现字符串的逆序输出。 1002题是一个求最大公约数的问题。我们可以使用辗转相除法来解决,即先求出两个数的余数,然后将被除数更新为除数,将除数更新为余数,直至两个数的余数为0。最后的被除数就是最大公约数。 1003题是一个比较简单的排序问题。我们可以使用冒泡排序算法来解决,即每次比较相邻的两个元素,如果它们的顺序错误就交换它们的位置。重复这个过程直至整个数组有序。 1100题是一个动态规划问题,要求计算给定序列中的最长上升子序列的长度。我们可以使用一个数组dp来保存到达每个位置的最长上升子序列的长度。每当遍历到一个位置时,我们可以将其和之前的位置比较,如果比之前位置的值大,则将其更新为之前位置的值加1,最后返回dp数组的最大值即可。 以上是对杭电OJ1000-1100题目的简要回答,涉及了一些基本的编程知识和算法思想。希望对您有所帮助。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值