nefu 25 计算高手

计算高手

Problem:25
Time Limit:1000ms
Memory Limit:65536K

Description

统计一个给定字符串中指定的字符出现的次数

Input

测试输入包含若干测试用例,每个测试用例包含2行,第1行为一个长度不超过5的字符串,第2行为一个长度不超过80的字符串。注意这里的字符串包含空格,即空格也可能是要求被统计的字符之一。当读到'#'时输入结束,相应的结果不要输出。

Output

对每个测试用例,统计第1行中字符串的每个字符在第2行字符串中出现的次数,按如下格式输出: 
c0 n0 
c1 n1 
c2 n2 
... 
其中ci是第1行中第i个字符,ni是ci出现的次数。

Sample Input

I
THIS IS A TEST
i ng
this is a long test string
#

Sample Output

I 2
i 3
  5
n 2
g 2 
注:第2个测试用例中,空格也是被统计的字符之一。

Hint

Source


//
//  main.cpp
//  shanshansahn
//
//  Created by liuzhe on 16/8/13.
//  Copyright © 2016年 my_code. All rights reserved.
//

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int main(int argc, const char * argv[]) {
    // insert code here...
    char s[105];
    char a[20];
    while(gets(a))
    {
        if(strcmp(a,"#")==0)
            break;
        gets(s);
        int len1=strlen(s);
        int len2=strlen(a);
        for(int i=0;i<len2;i++)
        {
            int count =0;
            for(int j=0;j<len1;j++)
                if(s[j]==a[i])
                    count++;
            cout<<a[i]<<' '<<count<<endl;
        }
    }
    
    
    //std::cout << "Hello, World!\n";
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值