poj 3468线段树区间更新

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 104022 Accepted: 32496
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

#include <cstdio>  
#include <cstring>  
#include <algorithm>  
#define ll long long  
#define lson l, mid, rt << 1  
#define rson mid + 1, r, rt << 1 | 1  
int const MAX = 1e5 + 5;  
ll sum[MAX << 2], add[MAX << 2];  
  
void PushUp(int rt)  
{  
    sum[rt] = sum[rt << 1] + sum[rt << 1 | 1];  
}  
  
void PushDown(int ln, int rn, int rt)  
{  
    if(add[rt])  
    {  
        sum[rt << 1] += (ll)ln * add[rt];  
        sum[rt << 1 | 1] += (ll)rn * add[rt];  
        add[rt << 1] += add[rt];  
        add[rt << 1 | 1] += add[rt];  
        add[rt] = 0;  
    }  
    return;  
}  
  
void Build(int l, int r, int rt)  
{  
    add[rt] = 0;  
    if(l == r)  
    {  
        scanf("%lld", &sum[rt]);  
        return;  
    }  
    int mid = (l + r) >> 1;  
    Build(lson);  
    Build(rson);  
    PushUp(rt);  
    return;  
}  
  
void Update(int L, int R, int c, int l, int r, int rt)  
{  
    if(L <= l && r <= R)  
    {  
        sum[rt] += (r - l + 1) * c;  
        add[rt] += c;  
        return;  
    }  
    int mid = (l + r) >> 1;  
    PushDown(mid - l + 1, r - mid, rt);  
    if(L <= mid)  
        Update(L, R, c, lson);  
    if(R > mid)  
        Update(L, R, c, rson);  
    PushUp(rt);  
    return;  
}  
  
ll Query(int L, int R, int l, int r, int rt)  
{  
    if(L <= l && r <= R)  
        return sum[rt];  
    int mid = (l + r) >> 1;  
    PushDown(mid - l + 1, r - mid, rt);  
    ll ans = 0;  
    if(L <= mid)  
        ans += Query(L, R, lson);  
    if(R > mid)  
        ans += Query(L, R, rson);  
    return ans;  
}  
  
int main()  
{  
    int n, q;  
    scanf("%d %d", &n, &q);  
    Build(1, n, 1);  
    while(q --)  
    {  
        char s[2];  
        scanf("%s", s);  
        if(s[0] == 'Q')  
        {  
            int l, r;  
            scanf("%d %d", &l, &r);  
            printf("%lld\n", Query(l, r, 1, n, 1));  
        }  
        else   
        {  
            int l, r, c;  
            scanf("%d %d %d", &l, &r, &c);  
            Update(l, r, c, 1, n, 1);  
        }  
    }  
}  

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值