hdu 4920矩阵连乘

Given two matrices A and B of size n×n, find the product of them. 

bobo hates big integers. So you are only asked to find the result modulo 3.
Input
The input consists of several tests. For each tests: 

The first line contains n (1≤n≤800). Each of the following n lines contain n integers -- the description of the matrix A. The j-th integer in the i-th line equals A  ij. The next n lines describe the matrix B in similar format (0≤A  ij,B  ij≤10  9).
Output
For each tests: 

Print n lines. Each of them contain n integers -- the matrix A×B in similar format.
Sample Input
1
0
1
2
0 1
2 3
4 5
6 7
Sample Output
0
0 1

2 1

//
//  main.cpp
//  160929
//
//  Created by liuzhe on 17/3/30.
//  Copyright © 2016年 my_code. All rights reserved.
//
//#include <bits/stdc++.h>

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <map>
#include <set>
#include <queue>
#include <deque>
#include <list>
#include <bitset>
#include <stack>
#define ll long long
#define mod 3
using namespace std;

ll a[805][805],b[805][805],c[805][805];

int main()
{
    int n;
    while(~scanf("%d",&n))
    //while(cin>>n)
    {
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            {
                scanf("%lld",&a[i][j]);
                a[i][j]=a[i][j]%mod;
            }
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
            {
                scanf("%lld",&b[i][j]);
                b[i][j]=b[i][j]%mod;
            }
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            for(int k=1;k<=n;k++)
            {
                for(int j=1;j<=n;j++)
                {
                    c[i][j]+=(a[i][k]*b[k][j]);
                }
                //c[i][j]=c[i][j]%mod;
            }
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<n;j++)
            {
                printf("%lld ",c[i][j]%mod);
            }
            printf("%lld\n",c[i][n]%mod);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值