2017多校联合第四场1011/hdu6181(次短路)

Two Paths

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 153428/153428 K (Java/Others)
Total Submission(s): 933    Accepted Submission(s): 431


Problem Description
You are given a undirected graph with n nodes (numbered from 1 to n) and m edges. Alice and Bob are now trying to play a game. 
Both of them will take different route from 1 to n (not necessary simple).
Alice always moves first and she is so clever that take one of the shortest path from 1 to n.
Now is the Bob's turn. Help Bob to take possible shortest route from 1 to n.
There's neither multiple edges nor self-loops.
Two paths S and T are considered different if and only if there is an integer i, so that the i-th edge of S is not the same as the i-th edge of T or one of them doesn't exist.
 

Input
The first line of input contains an integer T(1 <= T <= 15), the number of test cases.
The first line of each test case contains 2 integers n, m (2 <= n, m <= 100000), number of nodes and number of edges. Each of the next m lines contains 3 integers a, b, w (1 <= a, b <= n, 1 <= w <= 1000000000), this means that there's an edge between node a and node b and its length is w.
It is guaranteed that there is at least one path from 1 to n.
Sum of n over all test cases is less than 250000 and sum of m over all test cases is less than 350000.
 

Output
For each test case print length of valid shortest path in one line.
 

Sample Input
  
  
2 3 3 1 2 1 2 3 4 1 3 3 2 1 1 2 1
 

Sample Output
  
  
5 3
Hint
For testcase 1, Alice take path 1 - 3 and its length is 3, and then Bob will take path 1 - 2 - 3 and its length is 5. For testcase 2, Bob will take route 1 - 2 - 1 - 2 and its length is 3
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6181  6180  6179  6178  6177 
 

Statistic |  Submit |  Discuss |  Note
就是次短路,模板套一下就过了

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#define ll long long
#define INF 1000000000000000000
using namespace std;
typedef pair<ll,ll> P;
struct edge
{
    ll to,v;
    edge(ll to,ll v):to(to),v(v) {}
    edge() {}
};
const int maxn = 1e5+10;
//const int maxe = 100005;
ll V,E;
vector<edge> g[maxn];
ll d[maxn],d2[maxn];//最短距离和次短距离
void dijkstra(int s)
{
    priority_queue<P,vector<P>,greater<P> > pq;
    for(int i=1; i<=V; i++)
    {
        d[i]=INF;
        d2[i]=INF;
    }
    d[s]=0;
    pq.push(P(0,s));
    while(pq.size())
    {
        P nowe=pq.top();
        pq.pop();
        if(nowe.first>d2[nowe.second]) continue;  //如果这个距离比当前次短路长continue
        for(int v=0; v<(int)g[nowe.second].size(); v++)
        {
            edge nexte=g[nowe.second][v];
            ll dis=nowe.first+nexte.v;
            if(d[nexte.to]>dis)
            {
                swap(dis,d[nexte.to]);
                pq.push(P(d[nexte.to],nexte.to));
            }
            if(d2[nexte.to]>dis&&d[nexte.to]<dis)//保证最短路是小于这个次短路的
            {
                d2[nexte.to]=dis;
                pq.push(P(d2[nexte.to],nexte.to));//次短路的点进入pq
            }
        }
    }
}
int main()
{
    int s;//起点
    int t;
    cin>>t;
    //cout<<INF<<endl;
    while(t--)
    {
        scanf("%d%d",&V,&E);
        {
            for(int i=1; i<=V; i++)
                g[i].clear();
            for(int i=1; i<=E; i++)
            {
                ll f,t,v;
                scanf("%lld %lld %lld",&f,&t,&v);
                g[f].push_back(edge(t,v));
                g[t].push_back(edge(f,v));
            }
            s=1;//这题默认起点为1
            dijkstra(s);
            printf("%lld\n",d2[V]);
            //cout<<d2[V]<<endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值