HDU 1520 Anniversary party 树形dp

Problem Description
There is going to be a party to celebrate the 80-th Anniversary of the Ural State University. The University has a hierarchical structure of employees. It means that the supervisor relation forms a tree rooted at the rector V. E. Tretyakov. In order to make the party funny for every one, the rector does not want both an employee and his or her immediate supervisor to be present. The personnel office has evaluated conviviality of each employee, so everyone has some number (rating) attached to him or her. Your task is to make a list of guests with the maximal possible sum of guests' conviviality ratings.
 

Input
Employees are numbered from 1 to N. A first line of input contains a number N. 1 <= N <= 6 000. Each of the subsequent N lines contains the conviviality rating of the corresponding employee. Conviviality rating is an integer number in a range from -128 to 127. After that go T lines that describe a supervisor relation tree. Each line of the tree specification has the form:
L K
It means that the K-th employee is an immediate supervisor of the L-th employee. Input is ended with the line
0 0
 

Output
Output should contain the maximal sum of guests' ratings.
 

Sample Input
  
  
7 1 1 1 1 1 1 1 1 3 2 3 6 4 7 4 4 5 3 5 0 0
 

Sample Output
  
  
5
 











题意:给出一棵有根数,以及某个点的权值,
一个节点不能和它的父亲同时被选,问选出的点的最大权值和。

树形dp开始入坑……
一直对树形dp没什么感觉= =

这题……还好,但是多组数据真的有点坑,,
读入“以0 0终止”……具体怎么读入看我的代码吧。。

首先选出了最高领导人(也就是它没有上级),
考虑一个点只有被选或者不被选,被选的时候,
显然要从它的儿子不被选的状态转移过来;
而这个点不被选的时候,
可以从儿子被选或者不被选的状态转移过来。
具体程序一遍dfs即可。




#include<bits/stdc++.h>
using namespace std;
const int 
	N=6005;
int n,Ecnt,a[N],into[N];
int f[N][2];
struct Edge{
	int next,to;
}E[N];int head[N];
void add(int u,int v){
	E[++Ecnt].next=head[u];
	E[Ecnt].to=v;
	head[u]=Ecnt;
}
void dp(int u){
	f[u][0]=0,f[u][1]=a[u];
	for (int i=head[u];i;i=E[i].next){
		int v=E[i].to;
		dp(v);
		f[u][0]+=max(f[v][0],f[v][1]);
		f[u][1]+=f[v][0];
	}
}
int main(){
	while (~scanf("%d",&n)){
		for (int i=1;i<=n;i++) scanf("%d",&a[i]);
		int x=-1,y=-1,root;Ecnt=0;
		memset(head,0,sizeof(head));
		memset(into,0,sizeof(into));
		while (~scanf("%d%d",&x,&y),x+y){
			into[x]++,add(y,x);
		}
		for (int i=1;i<=n;i++)
			if (!into[i]) root=i;
		dp(root);
		printf("%d\n",max(f[root][0],f[root][1]));
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值