Description
N个矩形,排成一排. 现在希望用尽量少的矩形海报Cover住它们.
Input
第一行给出数字N,代表有N个矩形.N在[1,250000] 下面N行,每行给出矩形的长与宽.其值在[1,1000000000]2 1/2 Postering
Output
最少数量的海报数.
Sample Input
5
1 2
1 3
2 2
2 5
1 4
1 2
1 3
2 2
2 5
1 4
Sample Output
4
HINT
单调栈水题。。
两个高度一致且中间比它们高的海报对才可以减少答案。
这样的话用一个单调栈即可。
当然此题还有不停找区间最高值,分治解决的方法。
#include<bits/stdc++.h>
using namespace std;
int n,stk[250001];
int main(){
scanf("%d",&n);
int x,top=0,ans=0;
for(int i=1;i<=n;i++){
scanf("%d%d",&x,&x);
while(x<=stk[top])
if(x==stk[top--])ans++;
stk[++top]=x;
}
printf("%d",n-ans);
return 0;
}