yy loves ac


Description

Yangyang takes part in the ACM Summer Training. She loves AC, but there is so much knowledge to learn, For example, Dynamic Programming, Greedy, Search, Graph, Data Structure, and so on. So she decides to ask some other ACMers for help. There are some details below:

There are M (1 <= M <= 20000) ACMers. As we know, ACMers are always busy, so she decides to ask each ACMer at most once.

After being helped, Yangyang will fell happy, The i-th ACMer will bring her Hi(1 <= Hi <= 2^13)Happiness. Moreover, Yangyang prefer to numbers that are power of 2, (that is to say, only 1, 2, 4, 8, 16 … 2^13 are valid value of the happiness)

Summer Training has N (1 <= N <= 20000) days. Yangyang have a threshold of happiness Ti (1 <= Ti <= 20000) at the i-th day. If the total happiness of the day is greater than or equal to Ti, this day will be a happy day for her. Yangyang wants to maximize the number of happy days, but she doesn’t know how to achieve the idea, so again she come to ask you for help, can you make her happy?

Input

There are multiple test cases.

In each test case, the first line contains two postive integers N,M, separated by a space, where N indicates the number of days, and M indicates the number of ACMers

The following N lines, each will contain a integer, the i-th integer indicates the threshold of happiness for the i-th day.

The following M lines, each will contain a integer, the i-th integer indicates the happiness which the i-th ACMer will bring to her.

Output

For each test case ,output an integer, the maximum number of happy days.

Sample Input

1 2

2

1

1

3 2

1

3

4

2

8
Sample Output

1

2
Author

Footmen

题目大意可以抽象成给定N个盒子和M件物品,问这些物品最多能装满几个盒子(物品的大小是2的幂,一个盒子的物品大小加起来大于等于该盒子的容量时即视为装满了)。

思路:二分+贪心

二分盒子数为num,由题可知,我们肯定是放入前num小容量的盒子,然后对于这num个盒子,我们用m个物品去填补它们,贪心的规则是每次选取一个体积最大的物品,放入num个盒子内体积最大的那一个(用优先队列来实现),如果盒子还未被填满,那么我们把这个新盒子(容量为原容量-物品容量)放入队列中,等待重新被填满,最后当物品放完时看盒子是否已经被填满了,如果填满了,那么说明该解是一个可行解。

<pre name="code" class="cpp">/*
 * hujx.cpp
 *
 *  Created on: 2014年10月2日
 *      Author: dell
 */
#include<stdio.h>
#include<iostream>
#include<string>
#include<string.h>
#include<algorithm>
#include<iomanip>
#include<vector>
#include<time.h>
#include<queue>
#include<stack>
#include<iterator>
#include<math.h>
#include<stdlib.h>
#include<limits.h>
//#define ONLINE_JUDGE
#define eps 1e-8
#define INF 0x7fffffff
#define FOR(i,a) for((i)=0;i<(a);(i)++)
#define MEM(a) (memset((a),0,sizeof(a)))
#define sfs(a) scanf("%s",a)
#define sf(a) scanf("%d",&a)
#define sfI(a) scanf("%I64d",&a)
#define pf(a) printf("%d\n",a)
#define pfI(a) printf("%I64d\n",a)
#define pfs(a) printf("%s\n",a)
#define sfd(a,b) scanf("%d%d",&a,&b)
#define sft(a,b,c)scanf("%d%d%d",&a,&b,&c)
#define for1(i,a,b) for(int i=(a);i<b;i++)
#define for2(i,a,b) for(int i=(a);i<=b;i++)
#define for3(i,a,b)for(int i=(b);i>=a;i--)
#define MEM1(a) memset(a,0,sizeof(a))
#define MEM2(a) memset(a,-1,sizeof(a))
const double PI=acos(-1.0);
template<class T> T gcd(T a,T b){return b?gcd(b,a%b):a;}
template<class T> T lcm(T a,T b){return a/gcd(a,b)*b;}
template<class T> inline T Min(T a,T b){return a<b?a:b;}
template<class T> inline T Max(T a,T b){return a>b?a:b;}
using namespace std;
#define N 20005
int n,m;
int a[N];
int b[N];
bool Check(int num){
	priority_queue<int> q;
	for(int i=0;i<num;i++){
		if(a[i]) q.push(a[i]);
	}
	int tot=m;
	while(!q.empty()){
		tot--;							//每次选取体积最大的物品
		if(tot<0) break;
		int p=q.top();					//每次选取体积最大的盒子
		q.pop();
		p = Max(0,p-b[tot]);
		if(p>0){							//如果该盒子还未被填满,那么就重新"生成"一个新的盒子,放入队列中,准备填充
			q.push(p);
		}
	}
	return q.empty();			//返回队列是否为空(即这num个盒子是否能被填满)
}
void solve(){
	int l=0,r=n;
	int ans=-1;
	while(l<=r){								//注意此处二分法的写法,为左闭右闭区间
		int mid = (l+r)/2;
		if(Check(mid)){
			l=mid+1;
			ans=Max(ans,mid);
		}else
			r=mid-1;
	}
	printf("%d\n",ans);
}
int main(){
#ifndef ONLINE_JUDGE
	freopen("in.txt","r",stdin);
	freopen("out.txt","w",stdout);
#endif
	while(scanf("%d%d",&n,&m)!=EOF){
		for(int i=0;i<n;i++)
			sf(a[i]);
		for(int i=0;i<m;i++)
			sf(b[i]);
		sort(a,a+n);
		sort(b,b+m);
		solve();
	}
return 0;
}





 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值