Unsupported Java Version: Cannot start under Java 1.7.0_151-b01: Java 1.8 or later is required.问题解决。

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/ThomasKUI/article/details/78370651

当我们在ubuntu 14.04下安装pycharm时,可能出现Unsupported Java Version: Cannot start under Java 1.7.0_151-b01: Java 1.8 or later is required.

解决方案:

  • 添加apt-get源
    sudo vim /etc/apt/sources.list.d/java-8-debian.list

deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main


  • 按ESC后输入:wq保存退出后执行
    sudo apt-key adv –keyserver keyserver.ubuntu.com –recv-keys EEA14886
    sudo apt-get update.
    sudo apt-get install oracle-java8-installer

  • 安装完毕,测试java版本:
    java –version

  • Make as default
    sudo apt-get install oracle-java8-set-default

  • 结束,可以安装pycharm了。

展开阅读全文

没有更多推荐了,返回首页