NYOJ 推桌子 220 贪心 + 区间问题

推桌子

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 3
描述
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager's problem.
输入
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case begins with a line containing an integer N , 1 <= N <= 200, that represents the number of tables to move.
Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t each room number appears at most once in the N lines). From the 3 + N -rd
line, the remaining test cases are listed in the same manner as above.
输出
The output should contain the minimum time in minutes to complete the moving, one per line.
样例输入
3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50
样例输出
10
20

30

思路1:

把房间编号转换为直线上的线段,那么该问题就转换为了区间问题,类比 多个活动至少需要几个房间的问题

可以按照区间起始位置升序排列,然后用优先队列记录结束时间

#include<bits/stdc++.h>
using namespace std;

struct Node{
	int s,e;
	bool operator<(const Node o)const{
		return s < o.s;
	}
}nodes[200+5];
priority_queue<int,vector<int>,greater<int> > pq;
int main()
	{
		int t,n;
		scanf("%d",&t);
		while(t--){
			scanf("%d",&n);
			int s,e;
			for(int i = 0; i < n; ++i){
				scanf("%d%d",&s,&e);
				if(s > e){
					int t = s;
					s = e;
					e = t;
				}
				nodes[i].s = s;
				nodes[i].e = e;
				if(s%2 == 0)
					nodes[i].s = s-1;//看图就知道了 区间转化
				if(e%2 == 1)
					nodes[i].e = e+1;
			}
			sort(nodes,nodes+n);
			while(!pq.empty())//注意每次需要清空队列
				pq.pop(); 
			int ans = 0;
			for(int i = 0; i < n; ++i){
				if(!pq.empty()){
					int end = pq.top();
					if(nodes[i].s >= end){
						pq.pop();
						pq.push(nodes[i].e);
					}
					else{
						++ans;
						pq.push(nodes[i].e);
					}
				}
				else{
					++ans;
					pq.push(nodes[i].e);
				}
			}
			printf("%d\n",ans*10);

			
		}
		
		
		return 0;
	}

思路二:找到最大重叠的部分 就是

#include<cstdio>  
#include<cstring>  
#include<algorithm>  
using namespace std;  
int main(){  
    int t,n,count[410],i,start,end,k;  
    scanf("%d",&t);  
    while(t--){  
        scanf("%d",&n);  
        memset(count,0,sizeof(count));  
        while(n--){  
            scanf("%d%d",&start,&end);  
            //可能出发位置比目的地房间大。  
            if(start>end){  
                //无论大小,我们都可以看做从小的房间移动到大的房间  
                k=start;  
                start=end;  
                end=k;  
            }  
            if(start%2==0)//考虑实际情况,出发房间为偶数是减一,可参照题中给出的图一  
               start-=1;  
            if(end%2==1)//目的地房间为奇数时加一  
               end+=1;  
            for(i=start;i<=end;++i)  
               count[i]+=10;  
        }  
        printf("%d\n",*max_element(count,count+400));//STL中寻找数列最大值函数  
    }  
    return 0;  
}  

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
x1y2 x2y3 x3y1-x1y3-x2y1-x3y2 是计算三角形面积的公式中的一部分。 在这个公式中,x1、x2、x3分别表示三角形的三个顶点的x坐标,y1、y2、y3分别表示三角形的三个顶点的y坐标。通过计算这个表达式的值,可以得到三角形的面积。<span class="em">1</span><span class="em">2</span><span class="em">3</span> #### 引用[.reference_title] - *1* [TetraCluster:使用并行Java 2库的Java并行程序。 该程序在群集并行计算机上运行,​​以从给定的点集中找到...](https://download.csdn.net/download/weixin_42171208/18283141)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] - *2* [线性代数有个题,求正交变换x=Qy,化二次型f(x1,x2,x3)=8x1x2+8x1x3+8x2x3为标准型求出特征值](https://blog.csdn.net/weixin_39956182/article/details/115882118)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] - *3* [nyoj-67-三角形面积(S=(1/2)*(x1y2+x2y3+x3y1-x1y3-x2y1-x3y2))](https://blog.csdn.net/weixin_30492601/article/details/99541033)[target="_blank" data-report-click={"spm":"1018.2226.3001.9630","extra":{"utm_source":"vip_chatgpt_common_search_pc_result","utm_medium":"distribute.pc_search_result.none-task-cask-2~all~insert_cask~default-1-null.142^v93^chatsearchT3_1"}}] [.reference_item style="max-width: 33.333333333333336%"] [ .reference_list ]

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值