0-1背包 (反向、概率)HDOJ 2955

 

Robberies

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 31576    Accepted Submission(s): 11460


 

Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.
 


For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.


His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

 

 

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

 

 

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

 

 

Sample Input

 

3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05

 

 

Sample Output

 

2 4 6

 

题目大意:

抢银行,给定最大承受风险,每个银行金额,需要承担的风险,问如何获得最大的金额而不被抓捕。

 

题目 因为 概率为 小数,所以选择 把金额作为背包容量,当以金额为容量时候,需要注意 此时变成了,恰好装满的情形。

因为 如果 不是恰好装满 会出现 比最优金额 大的金额 而使 其可以逃脱,但此时 不存在 这样的 银行金额的组合满足这样的条件。

dp[i] 表示 金额为I时候,能够逃跑的最大概率。

注意:多次抢银行成功概率应该变成累成 而不是累加。

code:

#include<iostream>
#include<stdio.h>
#include<vector>
#include<map>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<set>
#include<cmath>
#define INF 1 << 30;
using namespace std;
const int N = 105;
double dp[10005];
int cost[N];
double v[N];

int main()
    {
        int t;
        scanf("%d",&t);
        double p;
        int n;
        while(t--){
            memset(dp,0,sizeof(dp));
            memset(cost,0,sizeof(cost));
            scanf("%lf%d",&p,&n);
            p = 1-p;
            int sum = 0;
            for(int i = 1; i <= n; ++i){
                scanf("%d%lf",&cost[i],&v[i]);
                v[i] = 1-v[i]; // 本次逃走概率
                sum += cost[i];
            }
            dp[0] = 1; // 没抢 此时逃生的概率为1
            for(int i = 1; i <= sum; ++i)
                dp[i] = -INF; // 恰好装满的初始化
            for(int i = 1; i <= n; ++i){
                for(int j = sum; j >= cost[i]; --j){
                    dp[j] = max(dp[j],dp[j-cost[i]] * v[i]); // 注意这里的累乘
                }
            }
            bool flag = false;
            for(int i = sum; i >= 0; --i){
                if(dp[i] >= p){
                    printf("%d\n",i);
                    flag = true;
                    break;
                }
            }
            if(!flag){
                printf("%d\n",0);
            }
        }


        return 0;
    }

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值