状态压缩dp入门 POJ 3254

 

Corn Fields

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6321 Accepted: 3361

 

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N 
Lines 2..M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:

1 2 3
  4  


There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

 

题目大意:农夫有一块地,被划分为m行n列大小相等的格子,其中一些格子是可以放牧的(用1标记),农夫可以在这些格子里放牛,其他格子则不能放牛(用0标记),并且要求不可以使相邻格子都有牛。现在输入数据给出这块地的大小及可否放牧的情况,求该农夫有多少种放牧方案可以选择(注意:任何格子都不放也是一种选择,不要忘记考虑!

 

code:

#include<iostream>
#include<cstring>
#include<vector>
using namespace std;

const int MOD = 100000000;
const int MAXN = 20;
int top;
int cur[MAXN];
int dp[MAXN][5000];
int state[5000];
int n,m;

inline bool fit(int x,int i){  
	if(x&cur[i]) return false; //这里因为 cur中记录取反 其实也可以 不取反 x&cur[i] == x 则 x也是合法的 
	return true;
}

bool ok(int x){
	if(x&(x << 1))  // 判断相邻的1 如果有相邻1则为 false 
		return false;
	return true;
}

void init(){
	top = 0;
	int tol = 1 << n; 
	for(int i = 0; i < tol; ++i){
		if(ok(i)){
			state[top++] = i;  //记录所有的可能状态数 即 满足无相邻 1  
		}					   //之后的每行与前一行的判断中的状态都取自state[] 
	}
}

int main()
	{
		ios::sync_with_stdio(false);
		cin.tie(0);
		cout.tie(0);
		memset(dp,0,sizeof(dp));
		cin >> m >> n;
		init(); 
		for(int i = 0; i < m; ++i){
			int num;
			cur[i] = 0;
			for(int j = 0; j < n; ++j){
				cin >> num;
				if(num == 0){
					cur[i] += (1 << (n-j-1));  //注意这里是 +=  不是直接等于  并且取反了 为了fit函数服务 
				}
			}
		}
		// 合适的取 1  
		for(int i = 0; i < top; ++i){
			if(fit(state[i],0)){ 
				dp[0][i] = 1;  // 表示state[]中的 第 i个 状态满足 条件 
			}
		}
		
		for(int i = 1; i < m; ++i){
			for(int j = 0; j < top; ++j){
				if(!fit(state[j],i)) continue;
				for(int k = 0; k < top; ++k){
					if(!fit(state[k],i-1)) continue;
					if(!(state[j]&state[k])){ // 上下两行 满足不相邻 (state[] 中的数满足左右不相邻) 
						dp[i][j] = (dp[i][j] + dp[i-1][k])%MOD;
					}
					
				}
			}
		}
		int ans = 0;
		for(int i = 0; i < top; ++i){
			ans = (ans + dp[m-1][i])%MOD;
		}
		cout << ans <<endl;
		
		return 0;
	}

 

参考:

https://blog.csdn.net/harrypoirot/article/details/23163485  看的这个博客入门的。。。感谢

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值