28:Maximum sum

总时间限制: 1000ms 内存限制: 65536kB
描述
Given a set of n integers: A={a1, a2,…, an}, we define a function d(A) as below:
t1 t2
d(A) = max{ ∑ai + ∑aj | 1 <= s1 <= t1 < s2 <= t2 <= n }
i=s1 j=s2

Your task is to calculate d(A).
输入
The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, …, an. (|ai| <= 10000).There is an empty line after each case.
输出
Print exactly one line for each test case. The line should contain the integer d(A).
样例输入
1

10
1 -1 2 2 3 -3 4 -4 5 -5
样例输出
13
提示
In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.

Huge input,scanf is recommended.

从左向右求dp[i]、lt[i]
从右向左求dp[i]、rt[i]枚举两个子串的分隔点i

#include<stdio.h>
#include<algorithm> 
#include<iostream>
using namespace std;
const int INF=100005;
int a[INF];
int lt[INF];
int rt[INF];
int dp[INF];
int main()
{
    int i,j,c,n,sum;
    scanf("%d",&c);
    while(c--)
    {
        scanf("%d",&n);
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        dp[n+1]=dp[0]=-INF;
        lt[0]=rt[n+1]=-INF;
        //正
        for(i=1;i<=n;i++)
            dp[i]=max(dp[i-1]+a[i],a[i]);
        for(i=1;i<=n;i++)
            lt[i]=max(dp[i],lt[i-1]);
        //逆
        for(i=n;i>=1;i--)
            dp[i]=max(dp[i+1]+a[i],a[i]);
        for(i=n;i>=1;i--)
            rt[i]=max(dp[i],rt[i+1]);
        sum=-INF;
        for(i=1;i<=n;i++)
            sum=max(sum,lt[i]+rt[i+1]);
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值