hdu 3183 A Magic Lamp (贪心 or RMQ)

A Magic Lamp

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4308    Accepted Submission(s): 1782


Problem Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams.
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
 

Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
 

Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it.
 

Sample Input
  
  
178543 4 1000001 1 100001 2 12345 2 54321 2
 

Sample Output
  
  
13 1 0 123 321
 

Source

这题也可以用RMQ来写,不过我暂时还不会,等会了再补起来

分析:用贪心的想法,这题不能是将所有的数字都排一个序,然后删除最大的,因为有这样的例子,1869,如果是删除9是没有删除8得到的大。

正确的应该是找到第一个比相邻的要大的位置,然后删除该位置的数。因为如果这个数不删除,它最后得到的数一定比删除的该数的数要大。

#include <iostream>
#include <cstdio>
#include <cstring>
#define MAX_N 1005
using namespace std;

int main()
{
    char a[MAX_N];
    int m;
    while(cin>>a>>m)
    {
        int len=strlen(a);
        for(int i=1;i<=m;i++)
        {
            int j=0;
            while(j<len&&a[j]=='0') j++;
            while(j<len-1&&a[j]<=a[j+1]) j++; //这里只能是a[j]>a[j+1]时才能停下来
            for(int k=j;k<len;k++)
                a[k]=a[k+1];
        }
        int flag=0;
        for(int i=0;i<len-m;i++)
        {
            if(a[i]!='0'&&!flag)
            {
                flag=1;
                printf("%c",a[i]);
            }
            else if(flag) printf("%c",a[i]);
        }
        if(!flag) printf("0");
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值