hust 1010 The Minimum Length (KMP)

1010 - The Minimum Length

时间限制:1秒 内存限制:128兆

3105 次提交 1148 次通过
题目描述
There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A. For example, A="abcdefg". I got abcd efgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.
输入
Multiply Test Cases. For each line there is a string B which contains only lowercase and uppercase charactors. The length of B is no more than 1,000,000.
输出
For each line, output an integer, as described above.
样例输入
bcabcab
efgabcdefgabcde
样例输出
3
7
分析:由于这个串是全部由一个子串连成的,所以用主串的长度减去最后一个的next值就是子串的长度。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#define MAX_N 1000005
using namespace std;
char p[MAX_N];
int ne[MAX_N];
void makeNext(const char p[],int ne[])
{
    int len=strlen(p);
    ne[0]=0;
    for(int i=1,k=0;i<len;i++)
    {
        while(k>0&&p[i]!=p[k]) k=ne[k-1];
        if(p[i]==p[k]) k++;
        ne[i]=k;
    }
}
int main()
{
    while(~scanf("%s",p))
    {
        makeNext(p,ne);
        int len=strlen(p);
        printf("%d\n",len-ne[len-1]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值