hdu 4424 Conquer a New Region(并查集+贪心)

Conquer a New Region

Time Limit: 8000/4000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2363    Accepted Submission(s): 848


Problem Description
The wheel of the history rolling forward, our king conquered a new region in a distant continent.
There are N towns (numbered from 1 to N) in this region connected by several roads. It's confirmed that there is exact one route between any two towns. Traffic is important while controlled colonies are far away from the local country. We define the capacity C(i, j) of a road indicating it is allowed to transport at most C(i, j) goods between town i and town j if there is a road between them. And for a route between i and j, we define a value S(i, j) indicating the maximum traffic capacity between i and j which is equal to the minimum capacity of the roads on the route. 
Our king wants to select a center town to restore his war-resources in which the total traffic capacities from the center to the other N - 1 towns is maximized. Now, you, the best programmer in the kingdom, should help our king to select this center.
 

Input
There are multiple test cases.
The first line of each case contains an integer N. (1 <= N <= 200,000)
The next N - 1 lines each contains three integers a, b, c indicating there is a road between town a and town b whose capacity is c. (1 <= a, b <= N, 1 <= c <= 100,000)
 

Output
For each test case, output an integer indicating the total traffic capacity of the chosen center town.
 

Sample Input
  
  
4 1 2 2 2 4 1 2 3 1 4 1 2 1 2 4 1 2 3 1
 

Sample Output
  
  
4 3
 

Source

题意:有n个城镇n-1个条通道的连通图。每个城镇到其他城镇的最大容量为该路上的最小容量,问取哪个点,能使总的容量最大?


思路:考虑这个问题,假设有两个集合S1和S2,他们还没有连通,现在要确定取哪个点才能使容量最大?不妨设连接边容量最小且为c。
那么最后的容量应该为max{sum(s1)+c*cnt(s2),sum(s2)+c*cnt(s1)},这样就可以确定点在哪个集合中。
我们每次找最小的边然后将这个集合拆开,再接着往下找最小的边接着拆开。到最后就能确定是满足条件的点。而我们可以反着想,每次都找到最大的边,然后将两个集合连接起来确定点,最后就能确定到底是哪一个点了。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=200005;
long long sum[maxn];
int cnt[maxn],pre[maxn];
int n;
struct Edge
{
    int from,to,cost;
}q[maxn];
int find(int x)
{
    if(pre[x]==x)
        return x;
    return pre[x]=find(pre[x]);
}
void mix(int x,int y,int c)
{
    int a=find(x);
    int b=find(y);
    long long sum1=sum[a]+(long long)c*cnt[b];
    long long sum2=sum[b]+(long long)c*cnt[a];
    if(sum1>sum2)
    {
        cnt[a]+=cnt[b];
        sum[a]=sum1;
        pre[b]=a;
    }
    else
    {
        cnt[b]+=cnt[a];
        sum[b]=sum2;
        pre[a]=b;
    }
}
bool cmp(Edge a,Edge b)
{
    return a.cost>b.cost;
}
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=1;i<=n;i++)
        {
            sum[i]=0;
            pre[i]=i;
            cnt[i]=1;
        }
        for(int i=0;i<n-1;i++)
        {
            scanf("%d%d%d",&q[i].from,&q[i].to,&q[i].cost);
        }
        sort(q,q+n-1,cmp);
        for(int i=0;i<n-1;i++)
        {
            mix(q[i].from,q[i].to,q[i].cost);
        }
        printf("%lld\n",sum[find(1)]);
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值