poj 3468 A Simple Problem with Integers(线段树区间更新)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 122316 Accepted: 37938
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source


题意:有n个数q次操作,每次操作为Q时,是查询l到r的区间的和。操作为C时,是从l到r的每个数都加上一个值。

思路:线段树区间更新。注意懒惰标记也要开long long,不然会WA。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=100000;
long long tr[4*maxn];
long long add[4*maxn];
void pushup(int i)
{
    tr[i]=tr[i<<1]+tr[i<<1|1];
}
void pushdown(int i,int len)
{
    if(add[i])
    {
        add[i<<1]+=add[i];
        add[i<<1|1]+=add[i];
        tr[i<<1]+=add[i]*(len-len/2);
        tr[i<<1|1]+=add[i]*(len/2);
        add[i]=0;
    }
}
void build(int i,int l,int r)
{
    if(l==r)
    {
        scanf("%lld",&tr[i]);
        return;
    }
    int mid=(l+r)/2;
    build(i*2,l,mid);
    build(i*2+1,mid+1,r);
    pushup(i);
}
void update(int i,int l,int r,int x,int y,int c)
{
    if(x<=l&&r<=y)
    {
        add[i]+=c;
        tr[i]=tr[i]+(r-l+1)*c;
        return;
    }
    pushdown(i,r-l+1);
    int mid=(l+r)/2;
    if(x<=mid) update(2*i,l,mid,x,y,c);
    if(y>mid) update(2*i+1,mid+1,r,x,y,c);
    pushup(i);
}
long long query(int i,int l,int r,int x,int y)
{
    long long sum=0;
    if(x<=l&&r<=y)
    {
        sum+=tr[i];
        return sum;
    }
    pushdown(i,r-l+1);
    int mid=(l+r)/2;
    if(x<=mid) sum+=query(2*i,l,mid,x,y);
    if(y>mid) sum+=query(2*i+1,mid+1,r,x,y);
    pushup(i);
    return sum;
}
int main()
{
    int n,q,x,y,c;
    char str[10];
    while(~scanf("%d%d",&n,&q))
    {
        build(1,1,n);
        memset(add,0,sizeof(add));
        for(int i=1;i<=q;i++)
        {
            scanf("%s",str);
            if(str[0]=='Q')
            {
                scanf("%d%d",&x,&y);
                printf("%lld\n",query(1,1,n,x,y));
            }
            else
            {
                scanf("%d%d%d",&x,&y,&c);
                update(1,1,n,x,y,c);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值