hdu 4006 The kth great number(优先队列)

The kth great number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 13043    Accepted Submission(s): 5135


Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.
 

Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 
 

Output
The output consists of one integer representing the largest number of islands that all lie on one line. 
 

Sample Input
 
 
8 3 I 1 I 2 I 3 Q I 5 Q I 4 Q
 

Sample Output
 
 
1 2 3
Hint
Xiao Ming won't ask Xiao Bao the kth great number when the number of the written number is smaller than k. (1=<k<=n<=1000000).
 

Source
 

Recommend
lcy

题意:给了N次操作,操作“I”是往集合中加入一个数,操作“Q”是查询集合中第K大的数。

思路:

用优先队列做。时间复杂度为O(N*logk)。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>

using namespace std;
priority_queue<int,vector<int>,greater<int> > que;
int main()
{
    int n,k,x;
    char op[5];
    while(~scanf("%d%d",&n,&k))
    {
        while(que.size()) que.pop();
        for(int i=1;i<=n;i++)
        {
            scanf("%s",op);
            if(op[0]=='I')
            {
                scanf("%d",&x);
                if(que.size()<k)
                    que.push(x);
                else
                {
                    if(x>que.top())
                    {
                        que.pop();
                        que.push(x);
                    }
                }
            }
            else
            {
                printf("%d\n",que.top());
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值