hdu 6333 Problem B. Harvest of Apples(莫队算法)

Problem B. Harvest of Apples

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 3573    Accepted Submission(s): 1380


 

Problem Description

There are n apples on a tree, numbered from 1 to n.
Count the number of ways to pick at most m apples.

 

 

Input

The first line of the input contains an integer T (1≤T≤105) denoting the number of test cases.
Each test case consists of one line with two integers n,m (1≤m≤n≤105).

 

 

Output

For each test case, print an integer representing the number of ways modulo 109+7.

 

 

Sample Input

 

2 5 2 1000 500

 

 

Sample Output

 

16 924129523

 

 

Source

2018 Multi-University Training Contest 4

 

 

Recommend

chendu

 

题意:

C_{n}^{0}+C_{n}^{1}+...C_{n}^{m}的和

思路:

因为可以O(1)的从S(n,m)转移到S(n,m+1),S(n,m-1),S(n+1,m),S(n-1,m)。所以可以考虑莫队。

由S(n,m)到S(n,m+1)有,S(n,m+1)=S(n,m)+C(n,m+1)

而由S(n,m)到S(n+1,m),根据C_{n}^{m}=C_{n-1}^{m}+C_{n-1}^{m-1}

S(n+1,m)=2*S(n,m)-C(n,m)

所以我们就可以用莫队算法来求解了。

代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn=1e5+5;
const int mod=1e9+7;
typedef long long ll;
ll ans=1;
ll res[maxn];
ll fac[maxn]={1,1},inv[maxn]={1,1},f[maxn]={1,1};
struct node
{
    int l,r;
    int id;
}q[maxn];
int pos[maxn];
bool cmp(node a,node b)
{
    if(pos[a.l]==pos[b.l])
        return a.r<b.r;
    return pos[a.l]<pos[b.l];
}
ll cal(ll a,ll b)
{
    if(b>a)
        return 0;
    return fac[a]*inv[b]%mod*inv[a-b]%mod;
}
void init()
{
    for(int i=2;i<maxn;i++){
        fac[i]=fac[i-1]*i%mod;
        f[i]=(mod-mod/i)*f[mod%i]%mod;
        inv[i]=inv[i-1]*f[i]%mod;
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    int sz=sqrt(maxn);
    init();
    for(int i=0;i<maxn;i++){
        pos[i]=i/sz;
    }
    for(int i=1;i<=t;i++){
        scanf("%d%d",&q[i].l,&q[i].r);
        q[i].id=i;
    }
    sort(q+1,q+1+t,cmp);
    int L=1,R=0;
    for(int i=1;i<=t;i++){
        while(L<q[i].l) ans=(2ll*ans%mod-cal(L++,R)+mod)%mod;
        while(L>q[i].l) ans=(ans+cal(--L,R))%mod*f[2]%mod;
        while(R<q[i].r) ans=(ans+cal(L,++R))%mod;
        while(R>q[i].r) ans=(ans-cal(L,R--)+mod)%mod;
        res[q[i].id]=ans;
    }
    for(int i=1;i<=t;i++){
        printf("%lld\n",res[i]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Go语言(也称为Golang)是由Google开发的一种静态强类型、编译型的编程语言。它旨在成为一门简单、高效、安全和并发的编程语言,特别适用于构建高性能的服务器和分布式系统。以下是Go语言的一些主要特点和优势: 简洁性:Go语言的语法简单直观,易于学习和使用。它避免了复杂的语法特性,如继承、重载等,转而采用组合和接口来实现代码的复用和扩展。 高性能:Go语言具有出色的性能,可以媲美C和C++。它使用静态类型系统和编译型语言的优势,能够生成高效的机器码。 并发性:Go语言内置了对并发的支持,通过轻量级的goroutine和channel机制,可以轻松实现并发编程。这使得Go语言在构建高性能的服务器和分布式系统时具有天然的优势。 安全性:Go语言具有强大的类型系统和内存管理机制,能够减少运行时错误和内存泄漏等问题。它还支持编译时检查,可以在编译阶段就发现潜在的问题。 标准库:Go语言的标准库非常丰富,包含了大量的实用功能和工具,如网络编程、文件操作、加密解密等。这使得开发者可以更加专注于业务逻辑的实现,而无需花费太多时间在底层功能的实现上。 跨平台:Go语言支持多种操作系统和平台,包括Windows、Linux、macOS等。它使用统一的构建系统(如Go Modules),可以轻松地跨平台编译和运行代码。 开源和社区支持:Go语言是开源的,具有庞大的社区支持和丰富的资源。开发者可以通过社区获取帮助、分享经验和学习资料。 总之,Go语言是一种简单、高效、安全、并发的编程语言,特别适用于构建高性能的服务器和分布式系统。如果你正在寻找一种易于学习和使用的编程语言,并且需要处理大量的并发请求和数据,那么Go语言可能是一个不错的选择。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值