ZJUT1032(Fun Function)

Fun Function
Time Limit:1000MS  Memory Limit:32768K

Description:

We all love recursion! Don't we?
Consider a three-parameter recursive function w(a, b, c):
if a <= 0 or b <= 0 or c <= 0,
then w(a, b, c) returns: 1

if a > 20 or b > 20 or c > 20,
then w(a, b, c) returns: w(20, 20, 20)

if a < b and b < c,
then w(a, b, c) returns: w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns: w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input:

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output:

Print the value for w(a,b,c) for each triple.

Sample Input:

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output:

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1


本题的关键在于递归的另外一种表示方法:迭代法。我们知道,如果单纯通过建立递归函数来求解问题,思路虽然很清晰,但是会出现重复计算的问题。将递归问题看成是一颗递归树的形式就会很容易的看出,我们会多次计算相同的子树。所以我们采用迭代的形式。本题就可以将结果保存在三维数组当中。这样我们就可以节省一大部分时间。


示例代码:

#include<iostream>
#include<iomanip>
#include<vector>
#include<algorithm>
#include<map>
#include<string>
#include<cmath>
#include<set>


using namespace std;



int main()
{
	int M[21][21][21];
	int a,b,c;

	M[0][0][0] = 1;
	for(int i = 0 ; i < 21 ; i++)
		for(int j = 0 ; j < 21 ; j++)
			for(int k = 0 ; k < 21 ; k++)
			{
				if(i == 0 || j == 0 || k == 0)
				{
					M[i][j][k] = 1;
					continue;
				}
				else if(i < j && j < k)
				{
					M[i][j][k] = M[i][j][k-1] + M[i][j-1][k-1] - M[i][j-1][k];
					continue;
				}
				else
				{
					M[i][j][k] = M[i-1][j][k] + M[i-1][j-1][k] + M[i-1][j][k-1] - M[i-1][j-1][k-1];
					continue;
				}
			}

	while(cin>>a>>b>>c && !(a == -1 && b == -1 && c == -1))
	{
		if(a <= 0 || b<= 0 || c <= 0)
			cout<<"w("<<a<<", "<<b<<", "<<c<<") = "<<1<<endl;
		else if(a >20 || b > 20 || c > 20)
			cout<<"w("<<a<<", "<<b<<", "<<c<<") = "<<M[20][20][20]<<endl;
		else
			cout<<"w("<<a<<", "<<b<<", "<<c<<") = "<<M[a][b][c]<<endl;
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值