UVa10050:Hartals

题目:每隔一段时间就要举办活动(周期性),计算给定的时间内有多少天是有活动的(周末无活动, 需舍去)

注:从周日开始

Description

A social research organization has determined a simple set of parameters to simulate the behavior of the political parties of our country. One of the parameters is a positive integer h (called the hartal parameter) that denotes the average number of days between two successive hartals (strikes) called by the corresponding party. Though the parameter is far too simple to be flawless, it can still be used to forecast the damages caused by hartals. The following example will give you a clear idea:

Consider three political parties. Assume h1 = 3, h2 = 4 and h3 = 8 where hi is the hartal parameter for party i ( i = 1, 2, 3). Now, we will simulate the behavior of these three parties for N = 14 days. One must always start the simulation on a Sunday and assume that there will be no hartals on weekly holidays (on Fridays and Saturdays).

 

1

2

3

4

5

6

7

8

9

10

11

12

13

14

Days

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Su

Mo

Tu

We

Th

Fr

Sa

Su

Mo

Tu

We

Th

Fr

Sa

Party 1

 

 

x

 

 

x

 

 

x

 

 

x

 

 

Party 2

 

 

 

x

 

 

 

x

 

 

 

x

 

 

Party 3

 

 

 

 

 

 

 

x

 

 

 

 

 

 

Hartals

 

 

1

2

 

 

 

3

4

 

 

5

 

 


The simulation above shows that there will be exactly 5 hartals
 (on days 3, 4, 8, 9 and 12) in 14 days. There will be no hartal on day 6 since it is a Friday. Hence we lose 5 working days in 2 weeks.

In this problem, given the hartal parameters for several political parties and the value of N, your job is to determine the number of working days we lose in those Ndays.

Input

The first line of the input consists of a single integer T giving the number of test cases to follow.

The first line of each test case contains an integer N ( ) giving the number of days over which the simulation must be run. The next line contains another integer P ( ) representing the number of political parties in this case. The i­th of the next P lines contains a positive integer hi (which will never be a multiple of 7) giving the hartal parameter for party i ( ).

Output

For each test case in the input output the number of working days we lose. Each output must be on a separate line.


Sample Input

Sample Output

2

14

3

3

4

8

100

4

12

15

25

40

5

15

 


#include <stdio.h>

int main()
{
	int test;
	scanf("%d",&test);
	while(test--)
	{
		int arr[101]={0}, str[3651]={0};
		int day, count, i, j;
		scanf("%d%d",&day,&count);
		for(i=0; i<count; i++)
			scanf("%d",&arr[i]);
			
		//将其倍数的天数改成1	
		for(i=0; i<count; i++)
		{
			for(j=0; j<=day; j+=arr[i])
			{
				str[j]=1;
			}
		}
		
		//周末不算,定值为0
		for(i=0; i<=day; i+=7) str[i]=0;
		for(i=6; i<=day; i+=7) str[i]=0;
		
		int sum=0;
		for(i=1; i<=day; i++)
			sum+=str[i];
		
		printf("%d\n",sum);
		
	}
	
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值